1

enter image description here

Check out page takes so much of time in Magento 2.2.4. I tried to checkout the product in Magento 2 it takes so much of time

2
  • is this default magento2 checkout or any extensions??
    – Priya
    Jul 12 '18 at 5:49
  • yes it is default magento2 extension Jul 12 '18 at 5:59
2

I checked your site, it is throwing Javascript error. So the page is not loading at all.

There is no issue with the loading time but the issue is with the javascript error. This error is blocking to load the contents in the page and you see the loader which is never-ending.

Please check this screenshot.

enter image description here

Looks like there is issue with jQuery.Stellar.min.js.

Try to add this piece of code to the file in the beginning.

    require([
    'jquery'
], function ($) {

and at the end of the code close the "require" method with

});

It is because stellar js is using jquery object which has to be loaded through require js.

2
  • please check the console same issue in listing page as well, I think it is better you contact Porto theme support as it is related to the theme. Jul 12 '18 at 9:34
  • WI have done what you said, Thats working fine but when click on Place order, Its just loading only. check once Jul 17 '18 at 9:38
0

Make sure cache is enabled and that you are in production mode. Check the following 4 files and increase the memory limit from 756M to 2048M.

  1. .htaccess
  2. pub/.htaccess
  3. .user.ini
  4. pub/.user.ini

Temporarily add phpinfo(); to your index.php file and check the memory_limit setting.

You can also enable Magento’s profiler and find the bottleneck.

0
0

If it is default Magento2 checkout, it'll not take much time.

  1. Check any extensions are enabled in the checkout page.
  2. Please disable and then check.
1
  • no it is default magento. I am using porto theme Jul 12 '18 at 9:01

Not the answer you're looking for? Browse other questions tagged or ask your own question.