1

I have been battling this issue since we moved to Magento2. I figured it is probably just the way it is designed but truly frustrating. Currently, we are on version 2.2.3. Steps to recreate the issue:

Sales->Orders->Create New Order->Select Customer or Create New Customer

Uncheck the Same As Billing Address box, then change any information on the Shipping Address (or add new). I receive a Please Wait Loading icon for EVERY field. And you cannot tab through the process like the Billing Address so you have to select each field again with the cursor. This takes an extremely long time to complete the Shipping Address, when compared to the Billing Address which works perfectly fine. I have a feeling it has to do with the shipping quotes, but that shouldn't really matter until you select Get shipping methods and rates.

Every time a field is changed in the Shipping Address (this does not happen at all in the Billing Address) I am receiving 2 POST methods with 200 code. The requested url is ending with:

block/billing_method,shipping_address,totals,giftmessage,items,shipping_method,shipping_address?isAjax=true

Another issue tied to the one above. Say you have the Shipping Address correct and you start to get the Credit Card information from the customer. After all that information is entered, you notice a typo in the Shipping Address or the customer wants to change something. If you change anything in the Shipping Address it will clear the Credit Card information, requiring you to enter the information again. Which is a real headache, asking the customer for all the credit card information again.

Thanks!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.