1

I received an e-mail from paypal regarding their TLS 1.2 upgrade.

They have an extended page on what to do over here: https://www.paypal.com/us/webapps/mpp/tls-http-upgrade

As mentioned in this document you can do some checks if you have to do some changes. Which I did:

  1. Are you hosted? - Answer: Yes
  2. Does your system support TLS 1.2 and HTTP/1.1. I contacted my hosting about this and they upgraded the system to the latest Curl version. And they said now my system will now support TLS 1.2 and HTTP/1.1
  3. Have tou hard coded an earlier version of TLS and HTTP supported by the Paypal endpoints. I have no idea if this is the case in Magento. But I am still receiving mails from Paypal that action is required. So I guess I am missing something.

Together with the hosting we set up a test file to check if the connection is ok:

Contents of paypaltest.php file:

<?php

$ch = curl_init('https://tlstest.paypal.com');
curl_setopt($ch, CURLOPT_RETURNTRANSFER, true);
curl_setopt($ch, CURLOPT_SSLVERSION, 6);
$data = curl_exec($ch);
curl_close($ch);

echo $data;

?>

Result: PayPal_Connection_OK

I am running Magento 1.9.2.1. I would think this Magento version would include all settings to have PayPal work.

What I would like to know: - Do I needs some additional installation or version on my hosting? - Do I need to change some settings in Magento?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.