2

I have followed different posts in order to get the solution and the tab working, but It doesn't show up.

I have followed this ones:

Custom admin configuration tab not showing Magento CE 2.1

Magento Custom Module Not Showing

Not even the ones that they put as an example, here is the code:

enter image description here

module.xml:

    <?xml version="1.0"?>

    <config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        xsi:noNamespaceSchemaLocation="urn:magento:framework:Module/etc/module.xsd">
    <module name="MSP_ReCaptcha" setup_version="1.4.11"/>
</config>

acl.xml

    <config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:framework:Acl/etc/acl.xsd">
    <acl>
        <resources>
            <resource id="Magento_Backend::admin">
                <resource id="Magento_Backend::stores">
                    <resource id="Magento_Backend::stores_settings">
                        <resource id="Magento_Config::config">
                            <resource id="MSP_ReCaptcha::config" title="Google ReCaptcha" sortOrder="50" />
                        </resource>
                    </resource>
                </resource>
            </resource>
        </resources>
    </acl>
</config>

system.xml:

    <config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:module:Magento_Config:etc/system_file.xsd">
    <system>
        <tab id="msp_tab" translate="label" sortOrder="1000">
            <label>MSP_SECURITY</label>
        </tab>
        <section id="msp_securitysuite_recaptcha" translate="label" type="text" sortOrder="100" showInDefault="1"
                 showInWebsite="1" showInStore="1">
            <class>separator-top</class>
            <label>Google ReCaptcha</label>
            <tab>msp_tab</tab>
            <resource>MSP_ReCaptcha::config</resource>

            <group id="general" translate="label" type="text" sortOrder="10" showInDefault="1" showInWebsite="1"
                   showInStore="1">
                <label>General</label>
                <field >
                    <!-- lots of code -->
                </field>
            </group>
        </section>
    </system>
</config>

I run these commands:

rm -rf pub/static/*;
php bin/magento setup:upgrade;
php bin/magento cache:flush;  
2
  • Where do you want this tab? Jul 9, 2018 at 13:24
  • I would like to have the tab inside: Stores -> Configuration -> And then either in General or if there is the option; create a tab called Security and put in there the Google ReCaptcha
    – Raül
    Jul 10, 2018 at 6:17

2 Answers 2

0

If you are wanting this to show up in the Configuration section it looks right at first glance. Did you log out of the Admin and then back in?

1
  • I have tried and no changes anywhere..
    – Raül
    Jul 10, 2018 at 6:17
1

In the end it was just a newbie mistake. All my files were in local and not all of them did sync with remote server, so I didn't have all files correctly on remote where I could see the changes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.