1

I've just applied the security patches on Magento 1.9 and after that, my custom modules didn't work. I tried clearing the cache and index but nothing happened. When I tried visiting the URL of my custom module, it says 404 not found.

I tried this

die(Mage::app()->getConfig()->getNode()->asXML());

to check if my config.xml was there but it wasn't.

Here's my app/code/local/Custom/Product/etc/config.xml code

<?xml version="1.0"?>
<config>
<modules>
    <Custom_Product>
        <version>0.1.0</version>
    </Custom_Product>
</modules>
<frontend>
    <routers>
        <customproductview>
            <use>standard</use>
            <args>
                <module>Custom_Product</module>
                <frontName>customproductview</frontName>
            </args>
        </customproductview>
    </routers>
</frontend>
</config>

Here's my app/etc/modules/Custom_Product.xml code

<?xml version="1.0"?>
<config>
 <modules>
    <Custom_Product>
        <active>true</active>
        <codePool>local</codePool>
    </Custom_Product>
 </modules>
</config>

Is there anyone who experienced this issue? Thank you.

  • Can you tell us which patch you have applied? To check whether your module is properly enabled you must check the app\etc\modules\Custom_Product.xml for its status. Or you can remove its entry from core_resource table , clear the cache and check it again. – Knight017 Jul 9 '18 at 5:15
  • There's no entry on the core_resource because I didn't use any SQL on this module. Also, we installed all the patches required for the Magento 1.9.1.0. Here's the list. prntscr.com/k45e26. Thank you! – nosnevetzy Jul 9 '18 at 5:43
  • Make some typo mistake in your module's XML, reload frontend. Then check for the log files under /var/log folder in Magento. If the module is being read, you should see errors for the typo in logs. – Mohit Kumar Arora Jul 9 '18 at 6:20
  • @MohitKumarArora I already did your suggestion but I didn't see any errors related to my module. Does it mean even my Custom_Product.xml is not loading? But when I go to Configuration > Advanced, I can see it from the list. Nothing happened though even if I enable or disable it. – nosnevetzy Jul 9 '18 at 6:52
  • @nosnevetzy, loading module under Configuration > Advanced means that Custom_Product.xml is working fine. Nothing else. – Mohit Kumar Arora Jul 9 '18 at 6:55
0

Okay, so what I did is I transfer the module from app/code/local to app/code/community and change the Custom_Product.xml

<codePool>community</codePool>

Thanks for all the help!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.