1

Today I have installed Magento via the DirectAdmin installer.
The home page is working fine.

When I login as admin I get this error:

Warning: is_dir(): open_basedir restriction in effect. File(/etc/pki/tls/certs) is not within the allowed path(s): (/home/minergea/:/tmp:/var/tmp:/usr/local/lib/php/:/usr/local/php56/lib/php/) in /home/minergea/domains/minergear.eu/public_html/vendor/composer/composer/src/Composer/Util/RemoteFilesystem.php on line 914

How can I fix this?

I can't seem to figure it out.

2
0

Edit you composer.json file

find the line

"composer/composer": "@alpha"

change to

"composer/composer": "1.1.2 as 1.0.0-beta1"

Put disable-tls:true in composer.json file, as in following :

"config": {
"use-include-path": true 
"disable-tls": true
},

now run

composer update
0

I don't tested it bu try this:

  1. rootProject/composer.json around line 12,

    change "composer/composer": "@Alpha" to "composer/composer": "1.1.2 as 1.0.0-beta1"

  2. Run : composer selfupdate

Source : GitHub Stabilize Composer

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.