0

Configurable swatches Not working on product page it is not selection.

enter image description here

8
  • did you upgrade the Magento version? Jun 30, 2018 at 4:58
  • If i can upgrate the version.so it will be solve it.??
    – Vipin
    Jun 30, 2018 at 4:59
  • Please check your console, if there any js missing than copy the JS file from base to your custom theme. Jun 30, 2018 at 5:01
  • was loaded over HTTPS, but requested an insecure script 's7.addthis.com/js/250/addthis_widget.js'. This request has been blocked; the content must be served over HTTPS.
    – Vipin
    Jun 30, 2018 at 5:04
  • share your URL..I can look and suggest you Jun 30, 2018 at 5:06

2 Answers 2

0

Your actual issue is

TypeError: Product.ConfigurableSwatches is not a constructor

You can try two things:

  1. Check the Configurable swatches with default theme
  2. apply the changes as mentioned in below post

https://stackoverflow.com/questions/41845427/typeerror-product-configurableswatches-is-not-a-constructor-in-magento-1-9-3

0

I can see error in your console,

To resolve this issue you can do following.

1) Open this file: app/design/frontend/YourPackage/YourTheme/template/configurableswatches/catalog/product/view/type/configurable/swatch-js.phtml

2) Instead this:

<script type="text/javascript">
    document.observe('dom:loaded', function() {
        var swatchesConfig = new Product.ConfigurableSwatches(spConfig);
    });
</script>

do this:

<script type="text/javascript">
    document.observe('dom:loaded', function() {
        if (Product.ConfigurableSwatches) { //put this Extra validation
            var swatchesConfig = new Product.ConfigurableSwatches(spConfig);
        }
    });
</script>
2
  • Hi, i have try that but my problem not solved ..problem is (option-yellow is-media)
    – Vipin
    Jul 2, 2018 at 5:23
  • Correct hover showing (option-yellow is-media hover) but my code not showing hover ..
    – Vipin
    Jul 2, 2018 at 5:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.