0

I don't know how to implement this task. In admin page, I have stores->Configuration->Advanced->developer

I have to choose to Enabled Template Path Hints for Storefront "yes". I have to choose to Enabled Template Path Hints for Admin "yes".

But in Front-end and admin not display path hints.

  • If you find my answer helpful to you, Up vote and accept as answer to help other who encounter same problems like you !! – Vivek Jun 28 '18 at 5:06
  • Check with Vivek answer and it will not help then check my answer. I hope it will resolve your issue. – Nikunj Vadariya Jun 28 '18 at 5:14
  • I have post my answer please check one more configuration , it may be helpful to you to display template hints. – Emipro Technologies Pvt. Ltd. Jun 28 '18 at 5:39
1

You must need to switch to developer mode in order to enable Template Path Hints for Forntend and Admin as well.

Regarding guide to enable Template Path Hints in Magento 2 Check here

0

If you are using Magento 2.2 then on production mode, the template hint will not work. You need to change it to developer mode and check below the things.

You need to set scope Default store view or your current store view. If You have set Main Website in Current configuration scope.

After setting Current configuration as Your Default store view and check Yes for storepath hints for front and Blockpath hints as Yes.

0

To enable template path hints first you have to change your store view like below:

enter image description here

Note: If you are using multi store than you have to choose particular store view for ex: "English" or "French"

after that enter your IP address in below field:

stores->Configuration->Advanced->developer >Developer Client Restrictions enter image description here

After that choose Enabled Template Path Hints for Storefront to "yes" and Save your configuration and clear the cache.

0

If you are already doing configuration it means your are not in production mode.

First of all check configuration by store wise.

If it is okay then check one more configuration for developer restriction.

go to stores->Configuration->Advanced->developer >Developer Client Restrictionsenter image description here

Be sure that there is no IP set in this configuration. if yes then remove it otherwise set your IP there and check scope from store view.

0

If you have a multi-store site but switch to Single Store Mode, you may run into a problem I had - of being unable to change settings as the default store may no longer update core values. This meant I wasn't able to turn on hints using the admin UI.

What I had to do was go to the database & search for %hints% and find core_config_data rows where the template hints were set. I was then able to update the store where in my case the scope_id = 1, to set hints on or off. core_config_data template_hints

Doing this I was able to turn hints on/off as required in the database rather than the admin UI.

This is related to this issue product-updates-not-showing-on-front-end-store-scope-issue which shows a fix for related problems possibly encountered when switching to Single Store Mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.