1

I am getting this error:

Amazon_Core db schema version: defined in codebase - 2.0.12, currently installed - 2.0.4

and

Amazon_Core db data version: defined in codebase - 2.0.12, currently installed - 2.0.4

I have not been able to find any information on this issue, or a packagist repo that looks like the right choice for Amazon_Core. I also have not found anything in my composer.json that relates to Amazon_Core.

  • I just experienced this when upgrading to Magento 2.2.6 from .2.2.4. I'm not sure the proper method to fix this but I simply removed all the values throwing the error from the setup_module table and running the Magento setup:upgrade command. So if anyone else has this issue, that is what my fix was. – LucasMaliszewski Nov 28 '18 at 23:22
0

It turns out I had removed the composer package msp/owlcarousel2 which also included an msp/common. I had assumed these were both part of the msp/owlcarousel2 package, so I removed them from the magento modules and in composer, as I no longer needed the package for our project. I then ran composer update and checked out the site which gave me the error described in the question above.

When I re-installed the msp/owlcarousel2 package and then enabled the MSP_Common module in magento, the error cleared up. Sounds like I might be a slave to that install until I can figure out how to properly remove it.

0

It is what is says. The Amazon_Core referenced as an older version in the code base from the version installed. Disable and remove, and then reinstall. In my case, searching for "Amazon_Core" in all magento root dir:

$ egrep -ir Amazon_Core .

Resulted in a lot of instances where it is referenced, used, and logged. Also, I got a recommendation from the: "vendor/amzn/amazon-pay-and-login-magento-2-module/docs/installation.rst:*

Enable the extension:

   `php bin/magento module:enable Amazon_Core Amazon_Login Amazon_Payment`

Disable the extension:

   `php bin/magento module:disable Amazon_Core Amazon_Login Amazon_Payment`                                      

I disabled them, and the error disappeared. I think if you want to use these extensions, you need to update the packages first.

0

If you're not using Amazon payments you can remove via composer. Edit composer.json in web root

"require": {
        [...]
    },
    "replace": {
        "amzn/amazon-pay-sdk-php": "*",
        "amzn/amazon-pay-and-login-with-amazon-core-module": "*",
        "amzn/login-with-amazon-module": "*",
        "amzn/amazon-pay-module": "*"
    },
    "config": {
        [...]

Run composer install

This is safer than module enable / disable command

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.