0

I just manually installed Magento2 CE on Ubuntu server 18.04 with LAMP via composer, the install went ok and all checks were on green however the link given after installation to access the magento admin page is giving error 404.

To resolve this a few people say it should work by changing from the config:

sudo nano /etc/apache2/apache2.conf

From:

Options Indexes FollowSymLinks AllowOverride None Require all granted

To

Options Indexes FollowSymLinks AllowOverride All Require all granted

but is still not working, another tutorials also say to change the file pub/.htaccess to magento root folder which im guessing it would be located default on: /var/www/html/magento

However I'm new to Ubuntu commands and I'm unable to find any suggestions of hwo to do this, would it work with this?

sudo mv /var/www/html/magento/pub/.htaccess /var/www/html/magento

If, I tried it and is not working, any suggestions?? or anyone here who have fixed this issue before??

Thank you for your assistance.

0

Please try Following changes........

/etc/apache2/apache2.conf

<Directory /var/www/>
        Options Indexes FollowSymLinks
        AllowOverride All
        Require all granted
</Directory>

sudo a2enmod rewrite

sudo service apache2 restart

Try above config & let me know if face any issue

0

Please use .htaccess file which in magento fresh root file only.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.