1

Pulling my hair out here trying to troubleshoot the reason why some new products aren't displaying on the frontend. I've checked the usual stock, weight, visibility, etc and have reindexed and recached plenty of times.

Can anyone think of anything else that could be causing this?

(Also, these products are counted in the result counts for searches, but not actually shown)

Update: products can be accessed directly via their URL/ID, but they aren't showing up in the categories/search results.

  • Are all the products not showing up? – Vivek Kumar Jun 22 '18 at 16:02
  • Only new products aren't showing up, the old products do – brackfost Jun 22 '18 at 16:16
  • Do you have a multi store setup? – Vivek Kumar Jun 22 '18 at 16:24
  • No, just the one. – brackfost Jun 22 '18 at 16:34
1

A command I hadn't tried before fixed this:

bin/magento indexer:reset

In the past, I'd only used "reindex", but a reset was necessary in this case.

0

Is your product set to "enabled" and is the visibility set to "Catalog, Search"? Stock availability should also be set to "In stock".

Once you have confirmed that, if you are using any associated products, make sure at least one of them has stock.

From my experience once you have met the above conditions and reindexed/cache, your products should appear. If not it might be a conflict with one of your extensions or code.

It's strange that they are included in the result count in a search without being shown...

  • Yeah, I've checked all of this. Strange, right? – brackfost Jun 20 '18 at 14:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.