1

(Sorry if my english is bad, but is not my language)

My Magento version is 1.9.3.8

I tried to solved this error whit this in SSH:

php -f shell/compiler.php disable
php -f shell/compiler.php clear
php -f shell/compiler.php compile

But didnt work (with compile, and without it).

This is my config.xml:

<?xml version="1.0"?>
<config>
    <modules>
        <Mage_Gextorshop>
            <version>0.0.1</version>
        </Mage_Gextorshop>
    </modules>
    <global>
        <models>
            <mage_gextorshop>
                <class>Mage_GextorShop_Model</class>
            </mage_gextorshop>
        </models>
                <helpers>
                        <mage_gextorshop>
                                <class>mage_gextorshop_Helper</class>
                        </mage_gextorshop>
                </helpers>
        <events>
            <sales_order_save_commit_after>
                <observers>
                    <mage_gextorshop>
                        <class>mage_gextorshop/observer</class>
                        <method>logUpdate</method>
                        <type>singleton</type>
                    </mage_gextorshop>
                </observers>
            </sales_order_save_commit_after>
        </events>
    </global>
</config>

In LocalHost had the same problem and when I used the SSH commands, solved it. Also I uninstalled the custom module, used SSH commands and installed again the module but error continue.

Other similar questions that I found didnt help me.

8
  • Disable compilation, flush and clear the cache then try again. I would suggest you to check in includes/config.php all code should commented after fire that disable compilation command. – kunj Jun 14 '18 at 10:23
  • Code from includes/config.php is commented, but error still happens. – Exe Jun 14 '18 at 10:37
  • Just backup the var/cache and session folder then delete them try again after that in private browser window. – kunj Jun 14 '18 at 10:42
  • Same as always... error still there. – Exe Jun 14 '18 at 11:28
  • 1
    Try with '<type>model</type>' instead of '<type>singleton</type>'. – kunj Jun 14 '18 at 14:15
2

Try this:

<?xml version="1.0"?>
<config>
    <modules>
        <Mage_Gextorshop>
            <version>0.0.1</version>
        </Mage_Gextorshop>
    </modules>
    <global>
        <models>
            <mage_gextorshop>
                <class>Mage_GextorShop_Model</class>
            </mage_gextorshop>
        </models>
                <helpers>
                        <mage_gextorshop>
                                <class>mage_gextorshop_Helper</class>
                        </mage_gextorshop>
                </helpers>
        <events>
            <sales_order_save_commit_after>
                <observers>
                    <mage_gextorshop>
                        <class>mage_gextorshop/observer</class>
                        <method>logUpdate</method>
                        <type>model</type>
                    </mage_gextorshop>
                </observers>
            </sales_order_save_commit_after>
        </events>
    </global>
</config>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.