0

I create a small module who add a button to the wishlist page. I make a file wishlist_index_index.xml in

Vendor/Module/view/frontend/layout/

<?xml version="1.0"?>
<page xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:framework:View/Layout/etc/page_configuration.xsd">
<head>
    <css src="Vendor_Module::css/barcode.css" />
</head>
<body>
    <referenceContainer name="customer.wishlist.buttons">
        <block class="Magento\Framework\View\Element\Template" name="barcode" template="Vendor_Module::wishlist/barcode.phtml"></block>
    </referenceContainer>
</body>
</page>

Everything is working well on luma theme, my button is here. But when I put a custom theme, the button is not present is I not copy the wishlist_index_index.xml in my custom theme also. I'm not sure it's the default behaviour, but in my mind you have to do it only if you want to overide the module template.

Do you know what i'm doing wrong ? i'm not very familiar with magento2 frontend...

Thanks

4
  • css is loading on wishlist page? Jun 12 '18 at 20:14
  • yes i saw my css content (and style are applied).
    – Mitchum
    Jun 12 '18 at 20:41
  • @Mitchum have flush cache and deploy static data after change? Jun 13 '18 at 4:39
  • yes do it already. but found it, i already override the same file but for the default magento module that's why I got this i think.
    – Mitchum
    Jun 13 '18 at 6:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.