0

Need some help with an error. I've installed a third party module, it is a shipping module. After I've installed it and I go the shipping methods in the backend, I get this:

Fatal error: Class 'FANCourier_Ship_Helper_Data' not found in app/Mage.php on line 547

My config.xml looks like this:

<?xml version="1.0"?>
<config>
<modules>
    <FANCourier_Ship>
        <version>0.1.0</version>
    </FANCourier_Ship>
</modules>
<frontend>
    <routers>
        <ship>
            <use>standard</use>
            <args>
                <module>FANCourier_Ship</module>
                <frontName>ship</frontName>
            </args>
        </ship>
    </routers>
    <layout>
        <updates>
            <ship>
                <file>ship.xml</file>
            </ship>
        </updates>
    </layout>
</frontend>
<global>
    <models>
        <ship>
            <class>FANCourier_Ship_Model</class>
            <resourceModel>ship_mysql4</resourceModel>
        </ship>
        <ship_mysql4>
            <class>FANCourier_Ship_Model_Mysql4</class>
            <entities>
                <ship>
                    <table>ship</table>
                </ship>
            </entities>
        </ship_mysql4>
    </models>
    <resources>
        <ship_setup>
            <setup>
                <module>FANCourier_Ship</module>
            </setup>
            <connection>
                <use>core_setup</use>
            </connection>
        </ship_setup>
        <ship_write>
            <connection>
                <use>core_write</use>
            </connection>
        </ship_write>
        <ship_read>
            <connection>
                <use>core_read</use>
            </connection>
        </ship_read>
    </resources>
    <blocks>
        <ship>
            <class>FANCourier_Ship_Block</class>
        </ship>
    </blocks>
    <helpers>
        <ship>
            <class>FANCourier_Ship_Helper</class>
        </ship>
    </helpers>
</global>
<default>
         <carriers>
            <FANCourier>
                <showmethod>1</showmethod>
                <active>1</active>
                <model>ship/carrier_FANCourier</model>
            </FANCourier>
     </carriers>
   </default>

And I also have a Data.php file in the module's Helper folder that looks like this:

class FANCourier_Ship_Helper_Data extends Mage_Core_Helper_Abstract
{

}
1

So... after some research and trying different things, the solutions was recompiling.

In the backend go to System > Tools > Compilation and then hit Run Compilation process.

I think that after the config.xml and data.php solutions, it's the main cause and it will work on 93.4% causes of helper not found problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.