0

We have a single product with single price of 365 EUR and the store is located in EU. No matter where the customer is located, the price must always be 365 EUR and VAT is to be calculated from that total. Shipping is free.

I set the following options:

  • set Tax Zones with all EU countries and their VAT and then a single entry for "non-EU" countries with 0% VAT
  • set single Tax Rule that is applied to the product
  • enabled "cross border trade"
  • tax calculation based on "shipping address"
  • have set default country destination (and have set store's location)
  • set "including tax" to: catalog prices, shipping prices, display product prices in catalog, display shipping prices, display prices, display subtotal, display shipping amount
  • set "yes" to: include tax in order total, display full tax summary

Problem is that when viewing cart, product price is correctly shown as 365.00, but subtotal and total is shown as 301.65 which is wrong, total should always be 365.00 and VAT should be calculated from that total.

How to set Magento to always show desired price? By now I read a lot about this topic and latter also changed all the settings at random, reindexed and cleared cache countless times and still no joy.

Examples:

Netherlands:
VAT 21%: 63.35
Total: 365.00

Germany:
VAT 19%: 69.35
Total: 365.00

Non-EU:
VAT 0%: 0.00
Total: 365.00

As I pointed out, total must always be 365.00 and it must show that everywhere but VAT also needs to be calculated from total and shown appropriately. At the moment, total is shown as 301.65, which is wrong.

0

What's the VAT for the destination country in this example? If my math is correct, based on your example, then this is what I calculate:

product : €301.65
vat     :   63.35 = 21%
TOTAL   :  365.00

If your destination country in this example has a VAT of 21%, then your settings appear to be working correctly.

  • I have added examples ... – Kristjan O. Jun 11 '18 at 21:08
  • Awesome! So, does your totals screen display some sort of line item for VAT, or just a subtotal/total amount of €301.65, without displaying a line for VAT at all? – Nathan Casebolt Jun 11 '18 at 21:20
  • Well, it's a mess despite I think I set everything correctly: imgur.com/a/tXiRyXY – Kristjan O. Jun 11 '18 at 21:26
  • Okay, that helps - I can visualize what you're seeing now. How frustrating! Can you confirm that you've configured Stores > Configuration > Sales > Tax > Shopping Cart Display Settings to do what you want? – Nathan Casebolt Jun 11 '18 at 21:49
  • Yes, please see this: imgur.com/a/MiprMlJ So it should show the full amount and not total minus VAT. – Kristjan O. Jun 13 '18 at 12:02
0

A bug in Magento v2.2.3, reported for older versions too and still not fixed: https://github.com/magento/magento2/issues/7801

Solution was provided at the above link by @pixiemediaweb:

just to share, I had a similar issue where the prices in the catalogue, cart and orders were fine, but the sidebar on the checkout refused to add tax to the order summary - turned out to be an issue with layout file Magento_Checkout/layout/checkout_index_index.xml from the Luma theme. The components loading in the sidebar were that of Magento_Checkout/js/view/summary/grand-total instead of Magento_Tax/js/view/checkout/summary/grand-total. Compare yours with the master copy (https://github.com/pepe1518/magento2/blob/master/vendor/magento/module-tax/view/frontend/layout/checkout_index_index.xml) to confirm if you have the same issue.

For me it solved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.