0
Magento 1.9.1
Porto theme

There is a problem in the Product images tab in this version of Magento, where if the anti-virus software/firewall/Windows/browser security disables Javascript - it makes the upload images buttons disappear. This happens periodically when there is some kind of a security update that comes through. Do you know what we need to disable in order to make these buttons come back?

The other more important issue is - we actually can see and use the upload image buttons on one computer, however, when we do - we go through the motions but the image does not actually upload! What could be causing this type of an issue? I've already made a ticket with the hosting company about this as they change settings on our VPS server every once in a while but their level 1 support usually brushes me off. What would be the best things to check in order to troubleshoot this?

Updated: I have Google Chrome Version 66.0.3359.181 (Official Build) (64-bit), I have the Javascript ENABLED and the buttons still do not show. Still though - the more important issue for us is that on the machine where we actually have the buttons and go through the steps - the image does not actually upload.

  • On the machine where the upload works, open the developer tools and switch to the network tab. Upload an image. What does the HTTP response contain? Is there an error in the response? If so, post it here. If not, what do the logs on the server say (Magento logs and web server/php logs). – ProcessEight Jun 11 '18 at 13:02
  • Also, is this behaviour occurring in the Magento admin (Catalog, Manage Products, select product, Images tab) or is it in a custom part of Magento added by the theme? If it is the latter, best to seek support from the theme vendor. – ProcessEight Jun 11 '18 at 13:04
  • @sfrost2004 Thanks for helping. This is definitely happening in the Magento Catalog - Manage products. I asked the hosting company for help and they tried to fix it...now the photo they uploaded appears on the front end but not in the Product Images tab in the Admin panel. I can't access the machine with the buttons at the moment.. – Allysin Jun 11 '18 at 15:40
0

The problem is with flash being disabled in the browser (version 1.9.1 uses Flash to display the buttons and the image).

These are the steps to follow to enable Flash in Chrome:

Chrome comes built in with it's own version of Flash, you are not required to install a separate plugin to enable Flash in Chrome. Follow the steps below for enabling flash on all websites you visit or specific website domains.

To enable Flash for all websites, open your Chrome browser and type chrome://settings/content in the address bar, then press enter. Then on the Content Settings page, scroll down to Flash and select the button next to 'Allow sites to run Flash'. If you would like to enable Flash for only specific pages, select the 'Manage exceptions...' button to access the Flash exceptions.

You can also go straight to chrome://settings/content/flash to turn off the blocking and add https://www.YOURsite.com as an exception

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.