0

The recaptcha was using 1.0 which is disabled now by google.

The form.phtml in default/default/template/review had the following code:

require_once(__DIR__ . '/recaptchalib.php');

&

<?php echo recaptcha_get_html("some-key-was-here", null, true); ?>

I decided to just try and remove it instead of upgrading it.

I removed the two lines of code above and checked to see if the form was back to "stock" using an original file in diffcehcker, it was.

I'm still getting an Invalid captcha entered. Please try again. error when submitting the form though. I did not develop this website. Any ideas on why it would still be trying to validate the captcha after being removed? Where else should I be looking?

I have tried flushing the cache.

Thanks

  • It sounds like there may be a JavaScript file still included on the page that is checking for a valid CAPTCHA entry. Have you double checked what scripts are being added to the page using the browser console? – MagentoAaron Jun 7 '18 at 18:32
  • Also, rather than removing that code, have you tried just disabling the reCAPTCHA on the review form from the Admin? Configuration > Sales > Google API > Google reCAPTCHA > Enabled Routes > Product Review Form – MagentoAaron Jun 7 '18 at 18:37
  • @MagentoAaron That was my thought as well but I can't find any validation in any of the scripts being loaded on the page and it's not on in the form.phtml file itsel. I also don't have the Google reCAPTCHA option in Configuration > Sales > Google API. – user3330820 Jun 7 '18 at 18:48
  • Ah, looks like what I am referring to is a 3rd party extension that I've installed on all of my instances. – MagentoAaron Jun 7 '18 at 19:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.