1

I encountered a very weird issue. I am trying to run a very basic import data flow profile (done it a hundred times before) by using selected Magento columns: sku, category_ids and status which looks like this:

enter image description here

My csv file looks basic too:

sku,category_ids, status <-- column headers

100001, "10, 11, 12", ENABLED

100002, "10, 11, 14", ENABLED

100003, "10, 11, 15", ENABLED

I also tried using '1' for status:

sku,category_ids, status <-- column headers

100001, "10, 11, 12", 1

100002, "10, 11, 14", 1

100003, "10, 11, 15", 1

The run gives a success message (100% imported) but when looking up the item in backend Catalog -> Manage Products I am unable to find it.

upon further check in Magento's tables I found out that the items exists in table catalog_product_entity but its record is clearly deleted from catalog_product_flat_1 (fyi: in my config settings I have enabled 'Use Flat Catalog Product')

I also tried using only two mapped columns and csv consisting of sku,category_ids only, but the same: items is deleted from catalog_product_flat_1.

Anyone able to explain this phenomenon? Also: what can I do to get the lost items back to flat catalog?

Thanks a lot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.