0

We are facing a strange issue.

We have set up a sitewide discount rule for one week. The shopping cart pricing rule does not require any coupon code & is available for guests & logged-in users.

The rule is not getting applied on the cart and discount row does not show up.

Coupon: No Coupon 
uses per customer: 99 
From date: 5/24/2018 
To date: 5/31/2018 
Priority: 0 
Condition: If all of these conditions are TRUE (default) 
Percent of product price 
Discount: 10 
Max Qty: 99 
Free Shipping: No 
Stop further rules: No

Even if use coupon & apply that coupon as below - it says coupon applied, but discount row does not show up.

Coupon: May2018 
uses per customer: 99 
From date: 5/24/2018 
To date: 5/31/2018 
Priority: 0 
Condition: If all of these conditions are TRUE (default) 
Percent of product price 
Discount: 10 
Max Qty: 99 
Free Shipping: No 
Stop further rules: No

This means sitewide discount or coupons are not getting attached when they should be valid. Invalid coupons continue to give Invalid coupon error

Nothing was updated on the site. Any pointers would be a great help. Thank you

  • Have you set a condition yet? Try condition qty in cart is greater than 0. – Ricky Odin Matthews May 29 '18 at 12:21
  • I tried that. Doesn't work. The discount only shows up if the shipping address is set. However, because the discount has no relation to shipping charge, it should not be dependent on the address. Should show based on the basket. Weird. – tushonline May 30 '18 at 13:27
  • Any 3rd-party plugins that may interfere with the cart, e.g. adding free items etc? – Ricky Odin Matthews May 30 '18 at 13:51
  • I'm digging into that aspect. Will update what happens. Thanks – tushonline May 31 '18 at 14:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.