1

My default store works perfectly fine. I recently created a second store (each store is accesible through its own domain name) on the same magento installation and I noticed one error/bug in the checkout process.

After entering customer data in the first step of checkout, I click on "Continue" and the loading icon keeps spinning forever and there is nothing I can do to stop it or cancel. If I want to browse the store again I have to reload the website.

I attach 2 images of the Console logs. On the 2nd website I got some errors but dont know what they mean. The errors on the console appear when I click on the "Continue" button after filling the shipping information. Then the website freezes and the loading icon spins forever.

I've tried multiple times cleaning magento cache, browser cache, deploy static content, etc., but nothing works.

Console main website Console second website

XHR response

Developer mode test

EDIT - New screenshot from Response tab:

Response tab

It is worth mentioning again that the main store works perfectly fine. This issue occurs only in the 2nd store.

Complete code from response tab:

{"payment_methods":[{"code":"cashondelivery","title":"Pago en Oxxo / 7-Eleven"},{"code":"banktransfer","title":"Dep\u00f3sito o transferencia bancaria"}],"totals":{"grand_total":489,"base_grand_total":489,"subtotal":359,"base_subtotal":359,"discount_amount":0,"base_discount_amount":0,"subtotal_with_discount":359,"base_subtotal_with_discount":359,"shipping_amount":130,"base_shipping_amount":130,"shipping_discount_amount":0,"base_shipping_discount_amount":0,"tax_amount":0,"base_tax_amount":0,"weee_tax_applied_amount":null,"shipping_tax_amount":0,"base_shipping_tax_amount":0,"subtotal_incl_tax":359,"shipping_incl_tax":130,"base_shipping_incl_tax":130,"base_currency_code":"MXN","quote_currency_code":"MXN","items_qty":1,"items":[{"item_id":786,"price":359,"base_price":359,"qty":1,"row_total":359,"base_row_total":359,"row_total_with_discount":0,"tax_amount":0,"base_tax_amount":0,"tax_percent":0,"discount_amount":0,"base_discount_amount":0,"discount_percent":0,"price_incl_tax":359,"base_price_incl_tax":359,"row_total_incl_tax":359,"base_row_total_incl_tax":359,"options":"[]","weee_tax_applied_amount":null,"weee_tax_applied":null,"name":"Alcanc\u00eda de cer\u00e1mica"}],"total_segments":[{"code":"subtotal","title":"Subtotal","value":359},{"code":"shipping","title":"Shipping & Handling (Est\u00e1ndar - 1 a 4 d\u00edas h\u00e1biles)","value":130},{"code":"tax","title":"Impuestos","value":0,"extension_attributes":{"tax_grandtotal_details":[]}},{"code":"grand_total","title":"Total","value":489,"area":"footer"}]}}

NEW EDIT: Added response from estimateshipping xhr

Estimate shipping XHR

Code: [{"carrier_code":"tablerate","method_code":"bestway","carrier_title":"Est\u00e1ndar","method_title":"1 a 4 d\u00edas h\u00e1biles","amount":130,"base_amount":130,"available":true,"error_message":"","price_excl_tax":130,"price_incl_tax":130}]

  • Have you tried this commands: php bina/magento cache:flush, php bin/magento setup:di:compile, php bin/magento setup:static:deploy? – kunj May 25 '18 at 20:13
  • Yes, I've tried that already but doesn't work – Luis Garcia May 29 '18 at 2:37
  • 2
    Please share website URL if you can it will help to identify the issue. – kunj May 29 '18 at 4:28
  • Please disable minifying, bundling and merging JS files if they are enabled and share changes in browser console with us. – Roman Glushko Jun 2 '18 at 8:29
  • I've already added changes in console – Luis Garcia Jun 4 '18 at 21:08
0

The error that there's an error in your JSON config most likely means that a PHP error occurs. A custom extension could be the fault.

To debug this, open the Network-tab in your developer console and check the actual response of the XHR request.

It's also better to debug this on a local or development machine where you can set the deploy mode to "developer". This will disable minifying the Javascript files and you will see where the error exactly occurs.

Also check your system.log and exception.log files, as well as the webserver's error log files for PHP errors.

==EDIT==

I assume you are using Firefox, so this is where you have to look to get the error message (while in developer mode):

enter image description here

In my case it is a CSS file but that really does not make a difference - the response tab will show you the error message.

  • Added screenshot from Network tab – Luis Garcia May 29 '18 at 16:52
  • Added screenshot from test in developer mode – Luis Garcia May 29 '18 at 19:33
  • edited my answer – simonthesorcerer May 31 '18 at 16:34
  • Added screenshot from Response tab – Luis Garcia Jun 4 '18 at 21:07
  • Do you have the response from the estimateshipping xhr? – Kervin Ramen Jun 5 '18 at 17:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.