1

I have installed a module. it gives me below error.

enter image description here

I Have tried to increase the version to 2.0.3 then error is not showing up but the module is not working.

php bin/magento setup:upgrade

php bin/magento setup:di:compile
php bin/magento setup:static-content:deploy
php bin/magento cache:flush

Even after doing all this, this module is not working as expected.

How I can I remove the module completely from Magento and make a fresh Installation of the module.

I have tried removing the module and setup:upgrade & pasting again Code and setup:upgrade.

Cause this module is upgrading schema also. when I install it is not updating the Tables with new Column.

4 Answers 4

2

For completely remove the extension from your magento, you need to follow these steps.

  • First, disable the module. php bin/magento module:disable K2B_PickPay
  • Now upgrade of your database by setup upgrade command
  • Go to the database and find the table setup_module and search for your module entry "K2B_PickPay" and delete that.
  • Delete the database table that is related to this module.
  • Remove the code from app/code directory
  • Then remove all cache folders from var/ directory
  • Now execute these commands one by one.

php bin/magento setup:upgrade
php bin/magento setup:di:compile
php bin/magento setup:static-content:deploy
php bin/magento cache:flush

That's it. Your module is completely removed from Magento and you can make fresh installation again.

1

Remove K2B_Pickpay module from setup_module table.

Run below command

php bin/magento setup:upgrade
php bin/magento setup:static-content:deploy
php bin/magento cache:clean
0
1

To remove the module completely:

  • First, run the following command to disable the module:

php bin/magento module:disable K2B_PickPay

  • Remove module's entry from the setup_module table.
  • Remove all tables which were created by the module (if any).
  • Remove custom columns added by the module (if any).
  • To confirm that module has been uninstalled, run the following command from project's directory:

php bin/magento setup:upgrade

  • Flush Magento cache.
  • Copy module files again in the project's folder and re-run the following command:

php bin/magento setup:upgrade

and

php bin/magento module:enable K2B_PickPay

If your module has to deploy static content, then run the following command:

php bin/magento setup:static-content:deploy -f

0

You have imported a database with the older version. Due to that, this version issue came. I suggest go to your DB >> setup_module table >> find those two modules in that table >> update version as 2.0.3. And run setup:upgrade command.

Hope this will help you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.