0

I received a phone call from a customer who said a coupon code was not working. I then proceeded to Shopping Cart Price Rules in my Admin and the whole site crashed with an exception error. The report in log says the following

a:5:{i:0;s:23:"Unsupported data type N";i:1;s:1398:"#0 /home/and21159/public_html/lib/Unserialize/Reader/Arr.php(102): Unserialize_Reader_ArrValue->read('N', ';')
#1 /home/and21159/public_html/lib/Unserialize/Parser.php(53): Unserialize_Reader_Arr->read('N', ';')
#2 /home/and21159/public_html/app/code/core/Mage/Core/Helper/UnserializeArray.php(44): Unserialize_Parser->unserialize('a:7:{s:4:"type"...')
#3 /home/and21159/public_html/app/code/core/Mage/Rule/Model/Abstract.php(179): Mage_Core_Helper_UnserializeArray->unserialize('a:7:{s:4:"type"...')
#4 /home/and21159/public_html/app/code/core/Mage/Adminhtml/controllers/Promo/QuoteController.php(92): Mage_Rule_Model_Abstract->getConditions()
#5 /home/and21159/public_html/app/code/core/Mage/Core/Controller/Varien/Action.php(418): Mage_Adminhtml_Promo_QuoteController->editAction()
#6 /home/and21159/public_html/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(254): Mage_Core_Controller_Varien_Action->dispatch('edit')
#7 /home/and21159/public_html/app/code/core/Mage/Core/Controller/Varien/Front.php(172): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#8 /home/and21159/public_html/app/code/core/Mage/Core/Model/App.php(365): Mage_Core_Controller_Varien_Front->dispatch()
#9 /home/and21159/public_html/app/Mage.php(684): Mage_Core_Model_App->run(Array)
#10 /home/and21159/public_html/index.php(83): Mage::run('', 'store')
#11 {main}";s:3:"url";s:76:"/index.php/admin/promo_quote/edit/id/2/key/4943fbaea25dba236be939e69b17ad3c/";s:11:"script_name";s:10:"/index.php";s:4:"skin";s:5:"admin";}

How do I fix this?

2

Please See Below links and you need to update the code according to it:

Security Patch SUPEE-10415 - Possible Issues?

OR

https://gist.github.com/balloz/ceaf5feb5ac66caaa82342441d32aa88

You basically need to have SUPEE-8788 V2 installed.

Failing that download Magento 1.9.3.7 and copy

1- lib/Unserialize/Parser.php

2- lib/Unserialize/Reader/Arr.php

3- lib/Unserialize/Reader/ArrValue.php

4- lib/Unserialize/Reader/Null.php

files from that installation to your site and see if there are any changes between the files and overwrite them if there are.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.