0

I try to create a copy of my project.

First I duplicated the project and the database, then I tried to change web/unsecure/base_url and web/secure/base_url in core_config_data to the new url.

But I noticed that they are not appearing in the database? This is all:

enter image description here

I also changed app/etc/local.xml to point at my new database.

This is what I get in the frontend right now:

There has been an error processing your request SQLSTATE[HY000] [2002]

No such file or directory

...

Error log record number: 372605216729

1
  • I noticed that my duplicated database is only 15 MB big, I think I have to import the data again. This time I packed the 1.5 GB SQL file as zip, now it is only 82 MB ! I will report back. – Black May 23 '18 at 10:37
0

Try following query

For unsecure path

SELECT * FROM `core_config_data` WHERE `path` LIKE '%web/unsecure/base_url%'

For secure path

SELECT * FROM `core_config_data` WHERE `path` LIKE '%web/secure/base_url%'
0

Phpmyadmin has some restrictions to import a SQL file if the file is too big.

So you can do the following:

mysql -u {username} -p {databasename} < /home/{cpanelpath}/pubic_html/yourfile.sql

Hit Enter and enter the password.

1
  • What exactly is your command doing? – Black May 26 '18 at 5:52
0

It was because Phpmyadmin failed to import the sql file completly. I had to import each table by hand to make it work.

Hint: Use MySQL console to create a dump of the database, then import the dump via MySQL. Turn off FK-Check.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.