0

Automatic updates of foreign currency does not happen

bumped to the homepage by Community yesterday

This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.

  • Check my answer will solve your issue. – Nikunj Vadariya May 23 '18 at 10:24
0

Magento 2 gives you the option to update currency rates from one of the three options:

  • Yahoo Finance Exchange
  • Fixer.io
  • Webservicex

You need to specify which option you want to use for currency rates update. You also need to configure the update option you’ve selected.

Step 1: Go to Stores => Configurations (under Settings).

enter image description here

Step 2: Click on Currency Setup tab from the left sidebar in General configuration settings.

enter image description here

You’ll see Yahoo Finance Exchange, Fixer.io and Webservicex sections in the Currency Options page.

Step 3: Expand the section you want to use for currency rate import.

enter image description here

You’ll see the Connection Timeout in Seconds field in your selected import option.

Set the number of seconds for which your connection stays idle when trying to establish an import connection before it times out.

Step 4: Expand the Scheduled Import Settings section.

enter image description here

You’ll need to fill in the following details to schedule currency rates update import:

Enabled: Set this to “Yes” to automatically update currency rates.

Service: Select the service from where you want to update the currency rates.

Start Time: Set the time when your rate import should start.

Frequency: Set frequency of the rate updates. You can set the update frequency to:

  • Daily
  • Weekly
  • Monthly

Error Email Recipient: Specify an email address, where a notification should be sent if there is an error in the rate import process. Error Email Sender: Set which email should be used to send the error notification. Error Email Template: Set which email template should be used for error notification email.

Step 5: Click on Save Config button to save the currency rate update settings.

enter image description here

You’ll be prompted to refresh invalidated cache types through system pop-up message.

After all run command:

php bin/magento cache:flush

  • Thank You @NikunjVadariya However I am unable to work around with this. Could you please assist if I can share my login credentials with you? – Huzan Forbes May 24 '18 at 11:54
  • @HuzanForbes my skype id : nikunj.vadariya – Nikunj Vadariya May 24 '18 at 12:00
  • @HuzanForbes if my answer solves your concern then there is green right tick mark, hit that tickmark for right answer that will help future readers. – Nikunj Vadariya May 24 '18 at 12:01
0

In magento 2 latest version you usually face this problem. You can get latest currency rate using below module.

https://marketplace.magento.com/sanjay-module-custom-currency-updater.html

0

I created this extension https://github.com/thanhdv2811/Magento-2-Currency-Convert to update currency rate using other services to fix the magento currency auto-update issue

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.