2

I've just installed Magento but when I go to /sales (I'm french so I think it's the right path) I have an error:

Payment model name is not provided in config

How do I fix that?

Thanks

4 Answers 4

1

In magento app/etc/config.php

edit Amazon_Payment = 1

and run

php bin/magento cache:flush  
php bin/magento setup:di:compile
1

In my case, it was because I'm using Magento 2.2.4 and I disabled the Amazon Payment. If you did some order using the payment method you need to keep the module, or changing the orders that use this payment method directly on the database, using the table to doesn't show a payment method that is not enabled anymore. You can test to use:

MySQL:

update `sales_order_grid` set payment_method='checkmo';

Terminal:

n98-magerun2.phar module:enable --all
0

This is due to the PayPal Pay Later update in 2.4.3. For some reason they left out the so you will need to go into etc/config.xml in the <paypal_paylater> and add the Paypal Paylater and then flush the cache. Thanks digitalstudionw on twitter.

Original Article Link:https://www.reddit.com/r/Magento/comments/p9hg7i/magento_243_payment_model_name_is_not_provided_in/

0

Thanks! its working. Thanks digitalstudionw on twitter

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.