1

I've added a new attribute in

admin > Catalog > Attributes > Manage Attributes

but I did not add it to an attribute set as it will not be required on the frontend.

However now I can't see this newly created attribute when I go to edit a (simple) product anywhere?

Magento 1.9

Help appreciated, thank you

  • Have you assigned that attribute to attribute set? – Nikunj Vadariya May 21 '18 at 13:10
5

In order to see newly created attribute in the product edit page in admin panel, you need to go to:

Catalog > Attributes -> Manage Attribute Sets

then open appropriate attribute set and assign the attribute by dragging it into the attribute group.

Save the attribute set, reindex and check again.

Without assigning the attribute to the attribute set, it will not be visible in the product edit form in the admin panel.

  • OK I've added the attribute to the 'Default' attribute set (group=Product Attributes), re-indexed, flushed all caches - attribute still not appearing in the admin product edit form – gvanto May 22 '18 at 12:11
  • Please check which attribute set is being used to create product? – Mohit Kumar Arora May 22 '18 at 12:30
  • ok works for adding a new simple product (attribute appearing) but not editing an existing one … that normal? what if I want to view/edit this attribute value for lots of historical (existing) simple products ... ? – gvanto May 22 '18 at 12:39
  • Select the products from catalog -> manage products grid, then select Update Attributes from the actions dropdown and click on button. – Mohit Kumar Arora May 22 '18 at 12:42
  • 1
    @Rathinam, seems that you have messed up with some core functionality of Magento. Please check whether it may be helpful or not: stackoverflow.com/questions/29431225/… teamtreehouse.com/community/… – Mohit Kumar Arora Oct 22 '18 at 6:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.