2

Im trying to run my Integration test on magento2 but keep getting the same error.

Module 'Magento_CatalogSearch': Installing data...

[Magento\CatalogSearch\Model\Indexer\Scope\IndexTableNotExistException] Temporary table for index catalogsearch_fulltext doesn't exist, which is inconsistent with state of scope resolver

Exception trace:
 () at /var/www/html/magento2/vendor/magento/module-catalog-search/Model/Indexer/Scope/IndexSwitcher.php:58
 Magento\CatalogSearch\Model\Indexer\Scope\IndexSwitcher->switchIndex() at /var/www/html/magento2/vendor/magento/module-catalog-search/Model/Indexer/IndexSwitcherProxy.php:79
 Magento\CatalogSearch\Model\Indexer\IndexSwitcherProxy->switchIndex() at /var/www/html/magento2/vendor/magento/module-catalog-search/Model/Indexer/Fulltext.php:154
 Magento\CatalogSearch\Model\Indexer\Fulltext->executeFull() at /var/www/html/magento2/vendor/magento/module-indexer/Model/Indexer.php:412
 Magento\Indexer\Model\Indexer->reindexAll() at /var/www/html/magento2/vendor/magento/module-indexer/Model/Indexer/DependencyDecorator.php:248
 Magento\Indexer\Model\Indexer\DependencyDecorator->reindexAll() at /var/www/html/magento2/vendor/magento/module-catalog-search/Setup/InstallData.php:45
 Magento\CatalogSearch\Setup\InstallData->install() at /var/www/html/magento2/setup/src/Magento/Setup/Model/Installer.php:868
 Magento\Setup\Model\Installer->handleDBSchemaData() at /var/www/html/magento2/setup/src/Magento/Setup/Model/Installer.php:792
 Magento\Setup\Model\Installer->installDataFixtures() at n/a:n/a
 call_user_func_array() at /var/www/html/magento2/setup/src/Magento/Setup/Model/Installer.php:343
 Magento\Setup\Model\Installer->install() at /var/www/html/magento2/setup/src/Magento/Setup/Console/Command/InstallCommand.php:146
 Magento\Setup\Console\Command\InstallCommand->execute() at /var/www/html/magento2/vendor/symfony/console/Command/Command.php:242
 Symfony\Component\Console\Command\Command->run() at /var/www/html/magento2/vendor/symfony/console/Application.php:843
 Symfony\Component\Console\Application->doRunCommand() at /var/www/html/magento2/vendor/symfony/console/Application.php:193
 Symfony\Component\Console\Application->doRun() at /var/www/html/magento2/vendor/magento/framework/Console/Cli.php:104
 Magento\Framework\Console\Cli->doRun() at /var/www/html/magento2/vendor/symfony/console/Application.php:117
 Symfony\Component\Console\Application->run() at /var/www/html/magento2/bin/magento:23

I've tried the following: - composer update - composer upgrade - removed folder vendor and composer update

php bin/magento cache:flush php bin/magento setup:upgrade php bin/magento setup:di:compile php bin/magento indexer:reindex

But nothing worked.

I installed a clean magento2 setup and here It works. But i can't figure out why, al my custom code from app/code/{myvendor} from the original project were copied to the fresh install and still it works on the fresh install.

  • I have the same error when installing Magento 2.2.5 clean – St3phan Jul 10 '18 at 10:23
  • I also have this issue, have you found any fix ? – lracicot Sep 11 '18 at 15:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.