0

After upgrading Magento 2, The products detail page product images are not loading, but the product archive page thumbnails are loading or showing.

I have tried ..

  • Flushing all caches
  • granting permissions
  • esizing images

But nothing seems to work or solve the issue. Screenshot here

2 Answers 2

0

I have checked your screenshot.

You have to do the following step ----

  1. At first, you have to check your browser console to see any require js issue.
  2. Give permission pub/media folder sudo chmod 777 -R pub/media/

Let me know if will face any issue.

2
  • Thanks for the help. Here's the screenshot of errors the browser is throwing: prntscr.com/jk9120
    – P. Paul
    May 20, 2018 at 14:09
  • Reindex and compile solved the problem.
    – P. Paul
    May 23, 2018 at 3:35
0

In magento 2 view page Issue with breadcrumbs file in Magent_Catalog/templates/product/breadcrumbs.phtml

update below code:

"product": "<?= $block->escapeHtml($block->escapeJsQuote($viewModel->getProductName(), '"')); ?>"

you can do following:

<div class="breadcrumbs" data-mage-init='{
    "breadcrumbs": {
        "categoryUrlSuffix": "<?= $block->escapeHtml($viewModel->getCategoryUrlSuffix()); ?>",
        "useCategoryPathInUrl": <?= (int)$viewModel->isCategoryUsedInProductUrl(); ?>,
        "product": "<?= $block->escapeHtml($block->escapeJsQuote($viewModel->getProductName(), '"')); ?>"
    }
}'>
</div>

This site is temporarily in read-only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .