3

When I try to update magento 2.1.9 to 2.2.0 I am getting this error

Fatal error: Uncaught Error: Cannot instantiate interface Magento\Framework\Serialize\SerializerInterface in vendor/magento/framework/ObjectManager/Factory/Dynamic/Developer.php

I try to edit app/etc/dl.xml but I am not getting what to update in preference type

  • You just need to run php bin/magento setup:upgrade to fix that error. – Kingshuk Deb May 11 '18 at 9:49
  • terminal showing same error when I try to upgrade – kristy May 11 '18 at 9:56
  • Post your di.xml and ovveride class both – Impunkj May 11 '18 at 10:05
  • I add this in di.xml <preference for="Magento\Framework\Serialize\SerializerInterface" type="Magento\Framework\Serialize\SerializerInterface" /> then I got error Fatal error: Uncaught LogicException: Circular type preference: Magento\Framework\Serialize\SerializerInterface relates to Magento\Framework\Serialize\SerializerInterface and viceversa. – kristy May 11 '18 at 10:22
  • anyone know what type should be there in that di.xml code – kristy May 11 '18 at 10:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.