1

I am using magento 2.2.3 and php vesion is 5.6.3. After running the project It gives error "Magento supports PHP 7.0.2, 7.0.4, and 7.0.6 or later. Please read Magento System Requirements." Magento manual says that php 5.6 is a supporting version.How can I fix this issue?

Edit: The problem is that I don't want PHP 7.1 because it is not supported by a plug-in I am using. So I'd rather install 7.0.6 or some other PHP version in the 7.0.x series supported by Magento. But I am unable to install a specific version of PHP. How can I specify the exact version of PHP while installing in Ubuntu 16.04

  • You should update PHP to the newest version because Magento 2.2.3 using some function only available on PHP 7.0.x – Bill May 8 '18 at 10:08
  • Thank you! Previously I have tried to install php 7 by using the command below sudo apt-get install php7.0 which installed php7.0.3, That is not supported by magento2. Could you please explain how can I install specific version of php in ubuntu – Megha Pd May 8 '18 at 10:32
1

Magento 2.2.3 is only compatible with these PHP versions :

enter image description here

You can find that in magento devdocs here : https://devdocs.magento.com/guides/v2.2/install-gde/system-requirements-tech.html

Good luck !!!

  • Thank you! Could you please explain where I will get the magento 2 version – Megha Pd May 8 '18 at 10:20
  • Your welcome I did not really understand what do you want.Can you explain more to me plz – sami23 May 8 '18 at 10:24
  • I want a magento version that supports php5.6.x – Megha Pd May 8 '18 at 10:30
  • So then u should install magento 1.9 but for Magento 2 php version 5.6.3 is not supported. – sami23 May 8 '18 at 10:36
  • You can install Magento 2.1 with php version 5.6.5 – sami23 May 8 '18 at 10:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.