0

I started developing a magento 2 website a dedicated server with an IP lets say (85.85.85.85) with Centos 7 and when I finished my development I downloaded the whole html folder (magento root) with a mysql backup and I reformatted my dedicated server and i putted Centos 7 with Plesk. I followed an article about migrating my website and i uploaded the files restored the database, connect the database with the files, changed the core_config urls and when I hit my domain on browser its says me "File not found.". Some of my plesk error logs can be shown here(1.http://prntscr.com/jdtyyw 2.http://prntscr.com/jdtz8g 3.http://prntscr.com/jdtzkc 4.http://prntscr.com/jdtzox) If anyone knows what happens here please help me unstuck from this, Every help would be appreciated. Thank you!

-----EDIT----- I corrected the file permissions When I run the command line

php bin/magento setup:upgrade

its says me this message

[Exception]
Warning: file_get_contents (/var/www/vhosts/domainname/httpdocs/var/di/setup.ser) : 
failed to open stream: 
No such file or directory in /var/www/vhosts/domainname/httpdocs/lib/internal/Magento/Framework/App/ObjectManager/ConfigLoader/Compiled.php on line 28
0

It could be a permission issue,

Please follow this link to set the right permissions.

http://devdocs.magento.com/guides/v2.2/install-gde/prereq/file-system-perms.html

there is an answer here

https://magento.stackexchange.com/a/219944/31830

| improve this answer | |
  • I tried to use php bin/magento setup:upgrade and it showed me this: [Exception]Warning: file_get_contents (/var/www/vhosts/domainname/httpdocs/var/di/setup.ser) : failed to open stream: No such file or directory in /var/www/vhosts/domainname/httpdocs/lib/internal/Magento/Framework/App/ObjectManager/ConfigLoader/Compiled.php on line 28 – Rafail Mavrogordatos May 4 '18 at 20:32
  • any suggestion? – Rafail Mavrogordatos May 5 '18 at 11:41
  • Did you follow the link above? From magento website? – WISAM HAKIM May 5 '18 at 13:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.