0

I am upgrading Magento 2.2.3 to 2.2.4 and got this error when running the command setup:di:compile after successfully running setup:upgrade.

[RuntimeException]
Source class "\amazonClient" for "amazonClientLogger" generation does not exist.
5

Weird but got fixed by running following commands in the order:

bin/magento deploy:mode:set developer
bin/magento cache:clean
bin/magento setup:di:compile
bin/magento deploy:mode:set production
|improve this answer|||||
  • 2
    This is the kind of thing about M2 that scares me. Too often the solution is to try variations of compilation steps. – Rick Buczynski May 3 '18 at 22:14
  • I have no clue why but it worked for me aswell - error popped up from nowhere and got resolved by this answer – stetoc Jan 9 at 11:38
0

I had same Issue, While installing zip with sample data.

I've resolved it my PHP Version to 7.1.x

Before PHP was 7.0.x, Don't know why Magetnto 2.2.4 doesn't seems to be work with PHP 7.0.x.

As After i switched to 7.1.x it installed successfully..

Hope it will help others..!!

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.