1

I'm trying to update Magento 2.1.7 to Magento 2.2.x but I keep coming across this error when I run the upgrade command in the CLI.

Upgrading data.. Error converting field `value` in table `dgtl_quote_item_option` where `option_id`=1943, 1949 using Magento\Framework\DB\DataConverter\SerializedToJson.
Fix data or replace with a valid value.
Failure reason: 'Unable to unserialize value, string is corrupted.'

I'm not sure what has made the string corrupt - the string in the value column is indeed incomplete. Anyone had any similar issues?

I'm not sure how to get around this and resolve the problem. Any help would be massively appreciated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.