2

Hope that someone may provide some guidance with an issue at hand .. and my limited knowledge.

Issue: CAPTCHA activated but not showing up in front end, except for "Forgot password".

Environment: My dev and prod environments are running Magento CE 2.1.3, theme is Ultimo Infortis.

Steps to activate CAPTCHA:

  1. Backend Admin -> Stores -> Configuration -> Customer -> Customer Configuration -> Captcha: 1.1. Enabled Enable CAPTCHA on Storefront = "Yes" 1.2. Forms (selected all options: create user, login, forgot password, etc)
  2. Reindexed via SSH
  3. Backend Admin -> Flush cache

Test: Go to the portal, try to open an account or do whatever and the CAPTCHA does not show, except for "Forgot Password".

Note: If CAPTCHA gets disabled for all in the configuration, "Forgot Password" keeps showing it.

Any guidance on where to look at or something that can help with the resolution will be appreciated.

5
  • only for forgot password?
    – Amit Bera
    May 3, 2018 at 15:16
  • You may need to set "Number of Unsuccessful Attempts to Login" field value to 0
    – Amit Bera
    May 3, 2018 at 15:18
  • Hi Amit, tried it but unfortunately got the same results when tested a login.
    – user52863
    May 3, 2018 at 15:27
  • The common behavior is that: if I enable or disable all CAPTCHA options, the only one that shows is "Forgot password". The rest do not show CAPTCHA.
    – user52863
    May 3, 2018 at 15:29
  • Yes Amit. If I enable captcha for all possible operations, it only shows in "Forgot Password". If I disable captcha for all possible operations (including "forgot password") it continues showing in "forgot password".
    – user52863
    May 4, 2018 at 11:47

2 Answers 2

1

I was facing the same issue before and in my case it was caused by my theme's customer_account_login.xml file.

For example, if your theme is extending Magento_Blank theme, then you don't need to copy the entire contents of the customer_account_login.xml file to your theme to make changes to it --> this will "bug out" the CAPTCHA form.

The proper way to make changes is to use and to add, remove or move the elements as you want.

You can read instructions here on how to do that: http://devdocs.magento.com/guides/v2.2/frontend-dev-guide/layouts/xml-instructions.html

If you are facing the same issue, you can quickly test it by renaming/removing your theme's customer_account_login.xml and clearing cache.

Ref: CAPTCHA form not visible, after applying theme

1
  • Thanks , its works for me
    – matinict
    Feb 14, 2020 at 15:28
0

My problem has been fixed. The default title for the contact us page is "Create New Customer Account" so I overrode contact_index_index.xml to change the page title to "Contact Us" when I did that, I just copied the original file and added code to change the title. I had to remove the following XLM from contact_index_index.xml to get it to work.

Reference - https://github.com/magento/magento2/issues/9635

<referenceContainer name="content">
  <block class="Magento\Contact\Block\ContactForm" name="contactForm" template="Magento_Contact::form.phtml">
  <container name="form.additional.info" label="Form Additional Info"/>
  </block>
</referenceContainer>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.