1

I am using Wamp. Am trying to install Magento 2.2.4(Latest Version) on my local machine. But Getting 500 Internal Server Error. I have downloaded as a .zip format with no sample data. Tried to see any logs, but there is no log folder created under /var folder.

enter image description here

Added lines in rootfolder/index.php to show error on frontend. enter image description here

6
  • check permission May 3, 2018 at 12:21
  • But, am trying to install on my local machine(Windows). Do I have to check any .htaccess file?
    – Octopus
    May 3, 2018 at 12:27
  • Did you enable error reporting on ?
    – Pawan
    May 3, 2018 at 12:42
  • @Pawan: Do you mean "the second image which I attached"?
    – Octopus
    May 3, 2018 at 12:49
  • please check apache error log. May 3, 2018 at 13:12

3 Answers 3

3

Same error for me also, I have solved it by enabling the mod_version module in apache

To enable it go to http.conf in the conf folder and find a line that has mod_version in it.

Remove "#" from the beginning to uncomment it.

Then restart apache.

2
  • Good one, fixed my problem.
    – Condor
    Jun 26, 2018 at 11:20
  • Thanks SKP, I had the same problem, I was also getting 500 Internal Server Error and after uncommenting below line in http.conf file LoadModule version_module modules/mod_version.so line, I can start magneto installation. Nov 26, 2018 at 9:08
1

Try to enable php errors on index.php

write these two line in index.php

error_reporting(E_ALL);
ini_set('display_errors', 1);

and then run the page, it will show if any error exist.

May i know your php version ?

2
  • These are the version details. Apache -2.4.27, PHP-7.0.23
    – Octopus
    May 3, 2018 at 12:41
  • I have renamed .htaccess file under root folder and pub folder temporarily. But I know this is not a permanent solution.
    – Octopus
    May 3, 2018 at 13:09
1

In .htaccess, I found like


<IfVersion >= 2.4>
     Require all denied 
</IfVersion>

Which caused the error, since my local Apache version is 2.4.76

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.