3

Does anyone know how I could switch off WS-I compliance for a Magento 2 website, or even if it is possible?

Trying to connect to a shipping API (Royal Mail Click and Drop) and they say WS-I compliance needs to be off.

They also say it is possible to switch off WS-I compliance in Magento 2 but they have not been able to tell me how and I can't figure it out!

Any ideas much appreciated.

0

a simple google search for: WS-I compliance lead me to https://devdocs.magento.com/guides/m1x/api/soap/wsi_compliance.html

this is Magento 1, not 2, so Iam not sure if this helps there, too.

Else its maybe worth to create an Issue at https://github.com/magento/devdocs so they also add a manual for M2

0

DO NOT LISTEN TO ROYAL MAIL TECH SUPPORT! THEY DO NOT HAVE A CLUE!

I've been through the exact same issue and have had the exact same conversation with Royal Mail.

This issue has nothing to do with WS-I compliance, it's to do with API permissions for the correct resources.

When approving the APIs on the API tab when setting up the integration in Magento DO NOT do as the Royal Mail instructions tell you to and to click the "ALL" dropdown, this will not select all! Leave it on custom and go through and tick every single option manually as per the below image. Complete the rest of the integration setup and you should find that it now works.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.