0

On installing magento 1.4 on localhost i am getting an error as shown below

enter image description here

and there is back end message generate for this #406715812 error :

a:5:{i:0;s:160:"Deprecated functionality: iconv_set_encoding(): Use of iconv.internal_encoding is deprecated  in C:\xampp\htdocs\shop\lib\Zend\Validate\Hostname.php on line 438";i:1;s:1575:"#0 [internal function]: mageCoreErrorHandler(8192, 'iconv_set_encod...', 'C:\\xampp\\htdocs...', 438, Array)
#1 C:\xampp\htdocs\shop\lib\Zend\Validate\Hostname.php(438): iconv_set_encoding('internal_encodi...', 'UTF-8')
#2 C:\xampp\htdocs\shop\lib\Zend\Validate\EmailAddress.php(201): Zend_Validate_Hostname->isValid('gmail.com')
#3 C:\xampp\htdocs\shop\lib\Zend\Validate.php(212): Zend_Validate_EmailAddress->isValid('anilthakur.matr...')
#4 C:\xampp\htdocs\shop\app\code\core\Mage\Admin\Model\User.php(392): Zend_Validate::is('anilthakur.matr...', 'EmailAddress')
#5 C:\xampp\htdocs\shop\app\code\core\Mage\Install\Model\Installer.php(220): Mage_Admin_Model_User->validate()
#6 C:\xampp\htdocs\shop\app\code\core\Mage\Install\controllers\WizardController.php(390): Mage_Install_Model_Installer->validateAndPrepareAdministrator(Array)
#7 C:\xampp\htdocs\shop\app\code\core\Mage\Core\Controller\Varien\Action.php(418): Mage_Install_WizardController->administratorPostAction()
#8 C:\xampp\htdocs\shop\app\code\core\Mage\Core\Controller\Varien\Router\Standard.php(254): Mage_Core_Controller_Varien_Action->dispatch('administratorPo...')
#9 C:\xampp\htdocs\shop\app\code\core\Mage\Core\Controller\Varien\Front.php(177): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#10 C:\xampp\htdocs\shop\app\code\core\Mage\Core\Model\App.php(304): Mage_Core_Controller_Varien_Front->dispatch()
#11 C:\xampp\htdocs\shop\app\Mage.php(596): Mage_Core_Model_App->run(Array)
#12 C:\xampp\htdocs\shop\index.php(78): Mage::run('', 'store')
#13 {main}";s:3:"url";s:49:"/shop/index.php/install/wizard/administratorPost/";s:11:"script_name";s:15:"/shop/index.php";s:4:"skin";s:7:"default";}

Please help to install Magento 1.4 on xammp server with PHP Version 5.6.34

0

Although, as per devdocs, Magento 1.4.x is not compatible with PHP 5.6.x, you can try the fixes mentioned in the link below to make it work:

https://gist.githubusercontent.com/renttek/29beaaa1e90909639501/raw/be5df0b33b72cdc2ab037d374802c53ccba066df/0001-BUGIFX-Magento-Zend-Framework-1-PHP5.6.patch

Notice: Don't make changes in the core file of Magento directly.

There are many similar questions asked before. You can take a look at the following links for reference:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.