I am facing weird problem that some customer can't login to their account.When customer try to login ,it redirect to same page without any error.it happens user who visited the site before. And for new user doesn't have any issues.if i clear cookie then everything is fine.These problem started when i shifted to new server which support HHVM.I am not able to find from where it redirects.After login it is going _loginPostRedirect action method and then redirecting to account/indexAction but it is not reaching to the this account/indexAction .Before this action some where it redirect to the login page again.Any one can help me to find from where it redirect or what is the issue with cookie?.

Thanks, Shabeer

5 Answers 5


If you feel like hitting it with very large hammer you could also try to purge content of var/session catalog.

  • This made my day - and coincidentally was the first approach I took :P
    – Moose
    May 11, 2016 at 6:34
  • Why do we have to do this? Is this a magento bug?
    – Black
    Feb 5, 2020 at 12:08

Most likely cookie domain is set (doesn't have to be)... you can try resetting it with mysql

update core_config_data set value = null where path = 'web/cookie/cookie_domain'

If that doesn't work, turn on errors in index.php and you should be getting something (perhaps permissions not set on a var directory).

  • 2
    I did both.There is no error it showing.Its something wrong with cookie.Old visitor can't login and if they clear the cookie then it works.How can check from where its redirect after login action and before going to account/index action Jun 6, 2014 at 15:31
  • TLDR: Try this solution where the most voted answer was to add .xyz.com note that "." at the beginning is important: magento.stackexchange.com/questions/104659/…
    – sodhancha
    Dec 12, 2020 at 10:22
  • Yes, add a period at the beginning for subdomain support. Dec 12, 2020 at 17:08

I hope there are issue form key in the customer login page add the below code

<input name="form_key" type="hidden" value="<?php echo Mage::getSingleton('core/session')->getFormKey() ?>" />

Try open admin panel in anonimus window and in Configuration > Web > Secure change http in Base URL to https, Use Secure URLs in Frontend and Use Secure URLs in Admin set Yes. Then delete var/cache and vavr/session, refresh admin login page and try to sign in.


Try this config>web>browser capabilities detection>Redirect to CMS-page if Cookies are Disabled it has to be YES

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.