0

I implemented this in fresh Magento 2.2.3 instalation: https://magenticians.com/add-custom-tab-magento-2/

After I make a change in code, like temporarily commented out:

<!-- <block class="Magenticians\Mymodule\Block\Mymodule" name="mymodule" template="Magenticians_Mymodule::mymodule.phtml" /> -->

and ran these in terminal: php bin/magento setup:upgrade php bin/magento cache:clean

...new tab is still there (changes didn't applied)...

I also tried activating developer mode: php bin/magento deploy:mode:set developer

Changes don't apply...

Please help.

8
  • have you tried removing var/generation ? Apr 25, 2018 at 15:09
  • there is no generation directory ibb.co/hFjptc Apr 25, 2018 at 15:16
  • Id go back and check to see if you have uploaded your code also check the eav_attribute_group just to make sure its not been added to there Apr 25, 2018 at 15:19
  • i am working on my local ubuntu machine Apr 25, 2018 at 15:24
  • if you followed the above tutorial did you remove the block within catalog_product_view.xml under <referenceBlock name="product.info.details"> Apr 25, 2018 at 15:30

1 Answer 1

0

You should try removing

pub/static/frontend
var/cache
var/page_cache
var/view_preprocessed

You can also try running the following command:

bin/magento c:f  && bin/magento s:up && bin/magento setup:di:compile && bin/magento setup:static-content:deploy -f

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.