0

My website's default URL is: dev4.wetag.ca

I added a second website to my Magento with the code: wetag_us I want to give it this URL: dev4.wetag.me

SO I changed it's url in the admin panel configuration, and following tutorials I added these lines in .htaccess:

<IfModule mod_rewrite.c>
Options +FollowSymLinks
RewriteEngine on

SetEnvIf Host .*dev4.wetag.me.* MAGE_RUN_CODE=wetag_usa
SetEnvIf Host .*dev4.wetag.me.* MAGE_RUN_TYPE=website



RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteCond %{REQUEST_METHOD} ^TRAC[EK]
RewriteRule .* - [L,R=405]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l
RewriteRule .* index.php [L] 
</IfModule>

I also tried this:

RewriteCond %{HTTP_HOST} ^(.*)dev4\.wetag\.me
RewriteRule .* – [E=MAGE_RUN_CODE:wetag_usa]
RewriteCond %{HTTP_HOST} ^(.*)dev4\.wetag\.me
RewriteRule .* – [E=MAGE_RUN_TYPE:website]

none of them seemed to work, when i visit the new domain it says:

This site can’t be reached dev4.wetag.me’s server IP address could not be found. Search Google for dev4 wetag me ERR_NAME_NOT_RESOLVED

I also tried to park dev4.wetag.me on dev4.wetag.ca through WHM, but still not working.

Am I missing something? Please help! Ps. I'm not a virtual machine or anything its on live server, CentOS.

Thank you !

  • Share DNS settings – df2k2 Apr 19 '18 at 1:32
0

In my opinion, you would have some DNS management that needs to be done. If you post your DNS settings for both of the domains, we can debug or eliminate it as the issue.


Double-check

Notice the wetag_us here:

I added a second website to my Magento with the code: wetag_us

but you have wetag_usa everywhere else:

SetEnvIf Host .dev4.wetag.me. MAGE_RUN_CODE=wetag_usa

and

RewriteCond %{HTTP_HOST} ^(.)dev4.wetag.me RewriteRule . – [E=MAGE_RUN_CODE:wetag_usa]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.