0

I was working on Magento 1.9.3.7 for a website.But when I clicked on clear cache it shows error and my website got down (404 error). I had an update at my Cpanel for Magento where my domain was in outdated installation. I updated it to 1.9.3.8 but still it shows the error

Please suggest me some solution,

2018-04-19T10:27:05+00:00 ERR (3): 
exception 'Mage_Core_Exception' with message 'Invalid block type: Mage_Bd_Product_Slider_Block_Featured' in app/Mage.php:595
Stack trace:
#0 app/code/core/Mage/Core/Model/Layout.php(495): Mage::throwException('Invalid block t...')
#1 app/code/core/Mage/Core/Model/Layout.php(437): Mage_Core_Model_Layout->_getBlockInstance('bd_product_slid...', Array)
#2 app/code/core/Mage/Core/Model/Email/Template/Filter.php(179): Mage_Core_Model_Layout->createBlock('bd_product_slid...', NULL, Array)
#3 [internal function]: Mage_Core_Model_Email_Template_Filter->blockDirective(Array)
#4 lib/Varien/Filter/Template.php(163): call_user_func(Array, Array)
#5 app/code/core/Mage/Core/Model/Email/Template/Filter.php(560): Varien_Filter_Template->filter('<p>{{widget typ...')
#6 app/code/core/Mage/Cms/Block/Page.php(123): Mage_Core_Model_Email_Template_Filter->filter('<p>{{widget typ...')
#7 app/code/core/Mage/Core/Block/Abstract.php(923): Mage_Cms_Block_Page->_toHtml()
#8 app/code/core/Mage/Core/Block/Abstract.php(641): Mage_Core_Block_Abstract->toHtml()
#9 app/code/core/Mage/Core/Block/Abstract.php(581): Mage_Core_Block_Abstract->_getChildHtml('cms_page', true)
#10 app/code/core/Mage/Page/Block/Html/Wrapper.php(52): Mage_Core_Block_Abstract->getChildHtml('', true, true)
#11 app/code/core/Mage/Core/Block/Abstract.php(923): Mage_Page_Block_Html_Wrapper->_toHtml()
#12 app/code/core/Mage/Core/Block/Text/List.php(43): Mage_Core_Block_Abstract->toHtml()
#13 app/code/core/Mage/Core/Block/Abstract.php(923): Mage_Core_Block_Text_List->_toHtml()
#14 app/code/core/Mage/Core/Block/Abstract.php(641): Mage_Core_Block_Abstract->toHtml()
#15 app/code/core/Mage/Core/Block/Abstract.php(585): Mage_Core_Block_Abstract->_getChildHtml('content', true)
#16 app/design/frontend/default/MAG080123/template/page/1column.phtml(55): Mage_Core_Block_Abstract->getChildHtml('content')
#17 app/code/core/Mage/Core/Block/Template.php(241): include('/home/subseatec...')
#18 app/code/core/Mage/Core/Block/Template.php(272): Mage_Core_Block_Template->fetchView('frontend/defaul...')
#19 app/code/core/Mage/Core/Block/Template.php(286): Mage_Core_Block_Template->renderView()
#20 app/code/core/Mage/Core/Block/Abstract.php(923): Mage_Core_Block_Template->_toHtml()
#21 app/code/core/Mage/Core/Model/Layout.php(555): Mage_Core_Block_Abstract->toHtml()
#22 app/code/core/Mage/Core/Controller/Varien/Action.php(390): Mage_Core_Model_Layout->getOutput()
#23 app/code/core/Mage/Cms/Helper/Page.php(137): Mage_Core_Controller_Varien_Action->renderLayout()
#24 app/code/core/Mage/Cms/Helper/Page.php(52): Mage_Cms_Helper_Page->_renderPage(Object(Mage_Cms_IndexController), 'home')
#25 app/code/core/Mage/Cms/controllers/IndexController.php(45): Mage_Cms_Helper_Page->renderPage(Object(Mage_Cms_IndexController), 'home')
#26 app/code/core/Mage/Core/Controller/Varien/Action.php(418): Mage_Cms_IndexController->indexAction()
#27 app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(254): Mage_Core_Controller_Varien_Action->dispatch('index')
#28 app/code/core/Mage/Core/Controller/Varien/Front.php(172): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#29 app/code/core/Mage/Core/Model/App.php(365): Mage_Core_Controller_Varien_Front->dispatch()
#30 app/Mage.php(684): Mage_Core_Model_App->run(Array)
#31 index.php(83): Mage::run('', 'store')
#32 {main}

i have deleted my 404 error and got some store id error

Warning: Uncaught Mage_Core_Model_Store_Exception in C:\xampp\htdocs\magento1\public_html\app\code\core\Mage\Core\Model\App.php:1377 Stack trace: #0 C:\xampp\htdocs\magento1\public_html\app\code\core\Mage\Core\Model\App.php(848): Mage_Core_Model_App->throwStoreException() #1 C:\xampp\htdocs\magento1\public_html\app\Mage.php(353): Mage_Core_Model_App->getStore(NULL) #2 C:\xampp\htdocs\magento1\public_html\app\code\core\Mage\Log\Helper\Data.php(47): Mage::getStoreConfig('system/log/enab...') #3 C:\xampp\htdocs\magento1\public_html\app\Mage.php(547): Mage_Log_Helper_Data->__construct() #4 C:\xampp\htdocs\magento1\public_html\app\Mage.php(811): Mage::helper('log') #5 C:\xampp\htdocs\magento1\public_html\app\code\core\Mage\Core\functions.php(247): Mage::log('Warning: requir...', 3) #6 C:\xampp\htdocs\magento1\public_html\app\Mage.php(690): mageCoreErrorHandler(2, 'require_once(C:...', 'C:\\xampp\\htdocs...', 690, Array) #7 C:\xampp\htdocs\magento1\public_html\app\Mage.php(690): require_once() #8 C:\xampp\htdocs\magento1\pu in C:\xampp\htdocs\magento1\public_html\app\code\core\Mage\Core\Model\App.php on line 1377

Fatal error: Mage::run(): Failed opening required 'C:\xampp\htdocs\magento1\public_html\errors\404.php' (include_path='C:\xampp\htdocs\magento1\public_html\app\code\local;C:\xampp\htdocs\magento1\public_html\app\code\community;C:\xampp\htdocs\magento1\public_html\app\code\core;C:\xampp\htdocs\magento1\public_html\lib;C:\xampp\php\PEAR') in C:\xampp\htdocs\magento1\public_html\app\Mage.php on line 690
  • can you check "var/log/exception.log" file and paster error here? – Chirag Rajput Apr 18 '18 at 11:36
  • there is no such file in var/log – deepak Apr 18 '18 at 13:33
  • You need to enable error reporting on and load page. stackoverflow.com/questions/17143406/… – Chirag Rajput Apr 18 '18 at 13:35
  • i have refereed the above link and uncommented the link but did not got error_reporting(E_ALL | E_STRICT); also there is a magento install in same domain with /dir and it is giving an error [Wed Apr 18 13:27:12 2018] [error] [client 192.185.129.69] client denied by server configuration: /home/***/public_html/**/app/etc/local.xml – deepak Apr 18 '18 at 14:17
  • i have restored my backup and error log is set to yes now i am getting some mage error 2018-04-19T09:00:24+00:00 ERR (3): exception 'Mage_Core_Exception' with message 'Invalid block type: Mage_Bd_Product_Slider_Block_Featured' in /home/subseatechnology/public_html/app/Mage.php:595 Stack trace: #0 /home/subseatechnology/public_html/app/code/core/Mage/Core/Model/Layout.php(495): Mage::throwException('Invalid block t...') #1 /home/subseatechnology/public_html/app/code/core/Mage/Core/Model/Layout.php(437): Mage_Core_Model_Layout- the error is too long – deepak Apr 19 '18 at 10:23
0

Please run this query in database.

SET SQL_SAFE_UPDATES=0; SET FOREIGN_KEY_CHECKS=0; UPDATE core_store SET store_id = 0 WHERE code='admin'; UPDATE core_store_group SET group_id = 0 WHERE name='Default'; UPDATE core_website SET website_id = 0 WHERE code='admin'; UPDATE customer_group SET customer_group_id = 0 WHERE customer_group_code='NOT LOGGED IN'; SET FOREIGN_KEY_CHECKS=1; SET SQL_SAFE_UPDATES=1;

Hope this will help you.

Thanks

  • SQL query: UPDATE core_store SET store_id =0 WHERE code = 'admin'; MySQL said: Documentation #1146 - Table 'prefix_database.core_store' doesn't exist do i need to edit any think in above query before running the query – deepak Apr 18 '18 at 14:42
  • If you have table prefix then you need to add it before table name. – Mayur Apr 18 '18 at 15:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.