1

I have managed to install the AOE Scheduler through ftp, although when I go to Scheduler under System it is completely blank. I have also cleared all the caches but that did not work either.

Can someone please assist me in the right direction.

I really appreciate any response or help. Thanks a lot in advance.

enter image description here

3
  • have you checked server error and exception logs? Apr 16, 2018 at 19:10
  • No sorry how do I check this?
    – Andy
    Apr 16, 2018 at 20:53
  • check the apache error logs (where they are depends on your operating system) and the files in var/log of your magento installation Apr 16, 2018 at 22:03

1 Answer 1

1

Try the following steps:

  1. Log out of Magento Admin and re-login. Check if AOE Scheduler page is now displaying. Else,
  2. Recompile Magento. In Magento installation root, run:

php shell/compiler.php compile

then disable compiler:

php shell/compiler.php disable

  1. Refresh and check again if AOE Scheduler is now displaying properly. Else,
  2. Re-install AOE Scheduler by ensuring that all file transfers were successful and existing AOE Scheduler files replaced during FTP transfer.
5
  • Thanks for your response @Ndianabasi Sorry I am new to magento, can you guide on me on how to recompile the root like you described?
    – Andy
    Apr 17, 2018 at 20:27
  • The fastest way to compile Magento is to use your bash shell. If you have access to shell on your hosting, then do the following: 1. Change your current directory to your Magento root directory. e.g. cd /var/www/<<magento_installation_root>> 2. Then run: php shell/compiler.php compile and php shell/compiler.php disable If you do not have access to shell on your hosting, do the following: 1. Log into Magento Admin. Then go to System > Tools > Compilation and click Run Compilation Process on the top-right corner. When the compilation is successful, click Disable.
    – Ndianabasi
    Apr 24, 2018 at 19:50
  • 1
    I do not gave access to the shell unfortunately. I just ran the Compilation process from Magento and then disabled it like you said but it still has not fixed the issue.
    – Andy
    Apr 26, 2018 at 8:11
  • Use need to set up a cron job or cron jobs to complete the installation process for Aoe Scheduler. Click on "See Instructions" on the page whose screenshot you shared above. You will see instructions for the cron job(s) you need to create on your server. Ask your hosting service provider to assist you in creating the cron job(s). If you are using Cpanel, there should be an interface for creating cron jobs. Howbeit, provide your hosting provider with the cron jobs instruction for Aoe Scheduler so that the heatbeat can start working. Cheers!
    – Ndianabasi
    Apr 27, 2018 at 16:52
  • 1
    When I click on "See Instructions" it does not do anything. I am completely stuck. I will make a payment if someone can fix it.
    – Andy
    May 1, 2018 at 11:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.