2

When I extracted the mailchimp extension in root folder. I came across this error

Class 'Ebizmarts_MailChimp_Helper_Data' not found in /home/occasion/public_html/occasionwearforkids.com.au/app/Mage.php on line 547

This is my data.php file enter image description here

And this is my config file enter image description here

1

Just refresh the Cache and if Compilation is enabled then you just need to disable it from

Admin > System > Tools > Compilation

If you are not able to open admin then go to the following path and comment some lines which are mentioned below in config.php.

Go to: Magento Root > includes > (open)config.php

#define('COMPILER_INCLUDE_PATH', dirname(__FILE__).DIRECTORY_SEPARATOR.'src');
#define('COMPILER_COLLECT_PATH', dirname(__FILE__).DIRECTORY_SEPARATOR.'stat');

I hope that'll help you.

1

You need to reset all caches and recompile if enabled. So try after refreshing cache and disabling compilation from backend.

  • i already did that but nothing happened? and how do i disable compilation? – rehan ansari Apr 16 '18 at 6:33
  • @rehanansari Admin > System > Tools > Compilation – Emipro Technologies Pvt. Ltd. Apr 16 '18 at 6:41
  • i cant open backend i am receiving this error Class 'Ebizmarts_MailChimp_Helper_Data' not found in /home/occasion/public_html/occasionwearforkids.com.au/app/Mage.php on line 547 @EmiproTechnologiesPvt.Ltd. – rehan ansari Apr 16 '18 at 6:46
  • @rehanansari please check my answer for how to disable compilation. – Emipro Technologies Pvt. Ltd. Apr 16 '18 at 6:52
1

I think in your site compilation is on So follow below solution

Solution 1:

Turn Off the compiler from your terminal steps :

  1. Open your terminal /connect your ssh access
  2. Go to your magento root via this command cd \yourpathtomagentoDir
  3. Fire this commnad php -f compiler.php disable
  4. After this do compile php -f compiler.php compile
  5. After this enable compile php -f compiler.php enable

Solution 2:

  1. Go to your module's xml file located in app/etc/modules and disable the module

  2. Clear the cache

  3. Now you are able to login in back end

  4. Disable the compiler and install your module

  5. Do compile and enable your magento compile

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.