1

I've recently started working with Magento and I'm facing a pretty basic problem that I can't manage to figure out. When creating a new product, from the admin page, Catalog -> Products -> New Product, I'm being redirected to a form. After completing the required fields, I receive an error message:

The value of attribute "sku" must be set

Which is a problem, as I don't have any SKU field in my form. I've looked for this problem, without any result, and I found out that SKU should be somewhere between Product Name and Price. Unfortunately, that's not my case.

Any ideas what should I do in this case? Thank you!

P.S. My version of Magento is the latest one, 2.2.3.

Edit 1: This is a screenshot of my form and error: screneshot

Edit 2: This is a screenshot of my default Attribute Set: enter image description here

  • can you put a link here to a screen shot for your form, this will help figure out what you missed – WISAM HAKIM Apr 15 '18 at 22:01
  • @zexperto-WISAMHAKIM Sure, I've edited my question. – eOf Apr 15 '18 at 22:09
  • did you try to check if the SKU is exist in the [Product Attributes], to double check it go to [store->attributes->product] search for SKU in attribute code column, if you found it -> go to [store->attributes->attribute set] and be sure that the SKU is added to "default" attribute set. Hope this will help you. – WISAM HAKIM Apr 15 '18 at 22:25
  • @zexperto-WISAMHAKIM Unfortunately, it is present in both places. You can find a screenshot in the question. I've also tried changing it's initial position on that list, but it keeps being ignored. Btw, thank you for your time! – eOf Apr 15 '18 at 22:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.