0

I am about to pull my hair out on this, been trying to do this for over a week and the transactional emails are not working in magento 1.8 CE.

Normally when trying to send email I get this error:

2014-06-05T01:44:15+00:00 ERR (3): 
exception 'Zend_Mail_Transport_Exception' with message 'Unable to send mail. ' in /home/client/public_html/lib/Zend/Mail/Transport/Sendmail.php:139
Stack trace:
0 /home/client/public_html/lib/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Sendmail->_sendMail()
1 /home/client/public_html/lib/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
2 /home/client/public_html/app/code/core/Mage/Core/Model/Email/Template.php(454): Zend_Mail->send()
3 /home/client/public_html/app/code/core/Mage/Core/Model/Email/Template.php(506): Mage_Core_Model_Email_Template->send('king@neton.com....', NULL, Array)
4 /home/client/public_html/app/code/local/AW/Raf/Helper/Notifications.php(41): Mage_Core_Model_Email_Template->sendTransactional('awraf_invite_te...', Array, 'king@neton.com....', NULL, Array, '1')
5 /home/client/public_html/app/code/local/AW/Raf/controllers/IndexController.php(172): AW_Raf_Helper_Notifications->send(Object(Varien_Object))
6 /home/client/public_html/app/code/core/Mage/Core/Controller/Varien/Action.php(418): AW_Raf_IndexController->inviteSendAction()
7 /home/client/public_html/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(250): Mage_Core_Controller_Varien_Action->dispatch('invitesend')
8 /home/client/public_html/app/code/core/Mage/Core/Controller/Varien/Front.php(172): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
9 /home/client/public_html/app/code/core/Mage/Core/Model/App.php(354): Mage_Core_Controller_Varien_Front->dispatch()
10 /home/client/public_html/app/Mage.php(683): Mage_Core_Model_App->run(Array)
11 /home/client/public_html/index.php(87): Mage::run('', 'store')
12 {main}

Then I installed SMTP Pro and tried to setup emails via Sendgrid. Even when I put the right credentials I get this error with ASchroder SMTP Pro:

SMTP Pro Self Test Results
Sending test email to your contact form address: info@domain.com.au from: info@clientdoman.com.au Unable to send test email.
Exception message was: Incorrect authentication data 
Please check the user guide for frequent error messages and their solutions.
Default templates exist.
Email communications are enabled.
Required database tables exist.

and the exception in the exception log is this:

2014-06-05T02:15:50+00:00 ERR (3): 
exception 'Zend_Mail_Protocol_Exception' with message 'Incorrect authentication data
' in /home/client/public_html/lib/Zend/Mail/Protocol/Abstract.php:431
Stack trace:
0 /home/client/public_html/lib/Zend/Mail/Protocol/Smtp/Auth/Login.php(95): Zend_Mail_Protocol_Abstract->_expect(235)
1 /home/client/public_html/lib/Zend/Mail/Protocol/Smtp.php(217): Zend_Mail_Protocol_Smtp_Auth_Login->auth()
2 /home/client/public_html/lib/Zend/Mail/Transport/Smtp.php(200): Zend_Mail_Protocol_Smtp->helo('localhost')
3 /home/client/public_html/lib/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Smtp->_sendMail()
4 /home/client/public_html/lib/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
5 /home/client/public_html/app/code/local/Aschroder/SMTPPro/controllers/Smtp/TestController.php(136): Zend_Mail->send(Object(Zend_Mail_Transport_Smtp))
6 /home/client/public_html/app/code/core/Mage/Core/Controller/Varien/Action.php(418): Aschroder_SMTPPro_Smtp_TestController->indexAction()
7 /home/client/public_html/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(250): Mage_Core_Controller_Varien_Action->dispatch('index')
8 /home/client/public_html/app/code/core/Mage/Core/Controller/Varien/Front.php(172): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
9 /home/client/public_html/app/code/core/Mage/Core/Model/App.php(354): Mage_Core_Controller_Varien_Front->dispatch()
10 /home/client/public_html/app/Mage.php(683): Mage_Core_Model_App->run(Array)
11 /home/client/public_html/index.php(87): Mage::run('', 'store')
12 {main}

Now all the sendgrid logins are correct. There was initially an issue with locale which I have fixed but still getting this error and I don't know where to even start looking for the problem, any help would be great.

Thanks

  • Can you describe your server setup in greater detail? – kab8609 Jun 5 '14 at 2:41
  • Well its a normal Cpanel with PHP and MySql. I can find out what version of PHP, MySQL, anything specific that you would like to know? – user7992 Jun 5 '14 at 2:51
  • hi, how you solved this, i am getting the same error,i have magento 1.9 with php 5.6.38 – Vikky Oct 31 '18 at 9:34
3

Found something from http://www.aschroder.com/2010/06/new-smtp-pro-magento-email-extension-released/ that might solve your issue.

Great extension, Ashley, thanks! Have been using it for about a year now without any issues.

For anyone on a VPS server suddenly getting “535 Incorrect authentication data” error, it is caused by the automatic WHM upgrade which changed one of the server email settings.

So, if you are on a VPS server using SMTP Pro and suddenly all outgoing emails stop working, here is one possible issue to check for:

1) Login to WHM
2) Under Server Configuration, select Tweak Settings
3) Click on the Mail tab
4) Scroll down to “Restrict outgoing SMTP to root, exim, and mailman (FKA SMTP Tweak)” and make sure it’s set to “OFF”
5) Scroll to the bottom of the page and click Save

Hope this helps someone with similar setup!
Peter
| improve this answer | |
-1

when we are working in localhost(127.0.0.1) loop-back mode mail never send. so for local server use http://www.magentocommerce.com/magento-connect/smtp-pro-email-free-custom-smtp-email.html

this module and configure it in your magento to send mail. outside ...

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.