0

After updating a Magento shop from 1.9.2.* to 1.9.3.7 and migrating it to a new server, everything works good so far. However, opening Customers -> Manage Customers in the Admin panel just shows no list. Please see the picture:

Manage Customers shows no list

There is no exception.log. But checking the system.log it shows the following Warning:

2018-04-08T06:13:47+00:00 ERR (3): Warning: include(Customer.php): failed to open stream: No such file or directory  in /var/www/.../htdocs/lib/Varien/Autoload.php on line 94
2018-04-08T06:13:47+00:00 ERR (3): Warning: include(Customer.php): failed to open stream: No such file or directory  in /var/www/.../htdocs/lib/Varien/Autoload.php on line 94
2018-04-08T06:13:47+00:00 ERR (3): Warning: include(): Failed opening 'Customer.php' for inclusion (include_path='...')  in /var/www/.../htdocs/lib/Varien/Autoload.php on line 94 

Unfortunately the warning does not contain a path. And Customer.php is pretty general. Doing a file search for Customer.php on the server returns multiple results in different directories.

What is the cause of the problem here? Thank you.

  • Is there any way I can trace and debug what Magento is trying to do there? – Mario Werner Apr 18 '18 at 2:07
  • Try and add the following code in lib/Varien/Autoload.php on line 93: echo $classFile . '<br>'; . This should help you to see which file is causing the issue. – Milan Simek Apr 23 '18 at 21:47
  • Also, enable error reporting in index.php – Milan Simek Apr 23 '18 at 21:47
  • The page title in your screenshot suggests an extension has overwritten the standard customer grid. Have you tried looking for the extension and disable it? – kiatng Apr 24 '18 at 8:20
  • 2
    I think there is some custom extension working on the Manage Customers page. Please check and try disabling the extension. It may not be compatible with the new version of your Magento store. – Mohit Kumar Arora Apr 25 '18 at 7:01
1
+50

Please debug the problem with the following steps:

  • First check the error logs of server. There should be some clue.
  • It seems that either this is a folder permission problem or you need to compile your code from System -> Tools -> Compilation to solve the error.
  • There may be some custom extension working on the Manage Customers page. Please check and try disabling the extension. It may not be compatible with the new version of your Magento store.

Please check and let me know if the above steps helped.

  • Problem was caused by the Templates Master Sold Together extension. Disabling it in /app/etc/modules/TM_SoldTogether.xml and clearing the cache, the Customer Manager works again. – Mario Werner Apr 26 '18 at 11:29
  • Please award bounty also if possible :) – Mohit Kumar Arora Apr 26 '18 at 11:43
  • True, sorry. Thought it is automatically when I accept your answer. Done. :) – Mario Werner Apr 26 '18 at 12:28
1

Try enabling error reporting in index.php file

error_reporting(E_ALL | E_STRICT);

to

error_reporting(E_ALL);

Set $_SERVER['MAGE_IS_DEVELOPER_MODE'] = true

and uncomment this line

#ini_set('display_errors', 1);

I guess the issue might be custom extension grid which might not have the updated code for the recent Magento Patch.

Thanks

1

In file {magento-root}/lib/Varien/Autoload.php, Magento is trying to include Customer.php

There can be multiple reasons due to which this error can come. But I think it is related to the compilation. Please check the compilation and try checking it by switching it off and then recompiling the code.

Upgrades should be done while keeping the compilation off.

If compilation is not the issue try disabling custom extensions and then check Magento (general debugging technique) as it will let you know the buggy extension which is not compatible with newer version of Magento or the patch.

Note: Take the backup of files and database.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.