0

The "Per page" items dropdown in my magento website is not working at all. The default value is set to 12 items (list includes 12,24,36) , but loads all products by default. When i select 24, the page loads to the following url

'/accessories?limit=24' 

but still loads all the products and no pagination appears. Could someone please point me in the right direction to fix this problem!

EDIT

The "Sort by" field is working. Only the Items per page is not.

  • Do you have any custom code related to the product listing? Make sure the collection is not loaded before it is passed to the pager block – Marius Jun 4 '14 at 8:22
  • @Marius I'm sorry, i'm quite new to magento , this is happening in the category list page. So no other modules are being loaded here. just the menu and the listing page. How can i check if the collection is being loaded? – user1634781 Jun 4 '14 at 8:27
  • Try this: magento.stackexchange.com/q/428/146 – Marius Jun 4 '14 at 8:32
  • Please make a screenshot of the settings and provide it here and the link to your webshop, this will contribute towards helping you with your problem. – user7964 Jun 4 '14 at 8:37
  • How many products are there? – TBI Infotech Jun 4 '14 at 9:14
1

I've seen something like that happen when people mix up Grid and List display modes. Basically if your Toolbar shows limits from List and you're trying to display Grid AND your chosen limit is not among Grid available limits, default is used. It happens usually with heavily modified category pages where one or another display method has been removed.

  • The layout has been edited (just basic styles) , but the list and grid values are not switched like you say. – user1634781 Jun 4 '14 at 9:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.