0

I am trying ton install the following GDPR module via command line for Magento version 2.2.1 : https://github.com/AdfabConnect/magento2gdpr

However, the install fails and produces the below error message.

  Problem 1
- Conclusion: don't install magento/module-sales 100.2.0-rc20
- Installation request for adfab/m2-module-gdpr ^1.0 -> satisfiable by adfab/m2-module-gdpr[1.0.0].
- Conclusion: don't install magento/framework 101.0.1|install magento/module-sales 100.2.0-rc20
- Conclusion: remove magento/framework 101.0.1|install magento/module-sales 100.2.0-rc20
- adfab/m2-module-gdpr 1.0.0 requires magento/module-sales 100.* -> satisfiable by magento/module-sales[100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.0.8, 100.0.9, 100.1.1, 100.0.10, 100.1.2, 100.1.3, 100.0.11, 100.1.4, 100.0.12, 100.1.5, 100.0.13, 100.1.6, 100.0.14, 100.1.7, 100.2.0-rc20, 100.1.8, 100.0.15, 100.0.16, 100.1.9, 100.1.10].
- magento/module-sales 100.0.2 requires magento/framework 100.0.* -> satisfiable by magento/framework[100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.0.8, 100.0.9, 100.0.10, 100.0.11, 100.0.12, 100.0.13, 100.0.14, 100.0.15, 100.0.16, 100.0.17, 100.0.18, 100.0.19, 100.0.20].
- magento/module-sales 100.0.3 requires magento/framework 100.0.* -> satisfiable by magento/framework[100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.0.8, 100.0.9, 100.0.10, 100.0.11, 100.0.12, 100.0.13, 100.0.14, 100.0.15, 100.0.16, 100.0.17, 100.0.18, 100.0.19, 100.0.20].
- magento/module-sales 100.0.4 requires magento/framework 100.0.* -> satisfiable by magento/framework[100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.0.8, 100.0.9, 100.0.10, 100.0.11, 100.0.12, 100.0.13, 100.0.14, 100.0.15, 100.0.16, 100.0.17, 100.0.18, 100.0.19, 100.0.20].
- magento/module-sales 100.0.5 requires magento/framework 100.0.* -> satisfiable by magento/framework[100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.0.8, 100.0.9, 100.0.10, 100.0.11, 100.0.12, 100.0.13, 100.0.14, 100.0.15, 100.0.16, 100.0.17, 100.0.18, 100.0.19, 100.0.20].
- magento/module-sales 100.0.6 requires magento/framework 100.0.* -> satisfiable by magento/framework[100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.0.8, 100.0.9, 100.0.10, 100.0.11, 100.0.12, 100.0.13, 100.0.14, 100.0.15, 100.0.16, 100.0.17, 100.0.18, 100.0.19, 100.0.20].
- magento/module-sales 100.0.7 requires magento/framework 100.0.* -> satisfiable by magento/framework[100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.0.8, 100.0.9, 100.0.10, 100.0.11, 100.0.12, 100.0.13, 100.0.14, 100.0.15, 100.0.16, 100.0.17, 100.0.18, 100.0.19, 100.0.20].
- magento/module-sales 100.0.8 requires magento/framework 100.0.* -> satisfiable by magento/framework[100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.0.8, 100.0.9, 100.0.10, 100.0.11, 100.0.12, 100.0.13, 100.0.14, 100.0.15, 100.0.16, 100.0.17, 100.0.18, 100.0.19, 100.0.20].
- magento/module-sales 100.0.9 requires magento/framework 100.0.* -> satisfiable by magento/framework[100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.0.8, 100.0.9, 100.0.10, 100.0.11, 100.0.12, 100.0.13, 100.0.14, 100.0.15, 100.0.16, 100.0.17, 100.0.18, 100.0.19, 100.0.20].
- magento/module-sales 100.0.10 requires magento/framework 100.0.* -> satisfiable by magento/framework[100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.0.8, 100.0.9, 100.0.10, 100.0.11, 100.0.12, 100.0.13, 100.0.14, 100.0.15, 100.0.16, 100.0.17, 100.0.18, 100.0.19, 100.0.20].
- magento/module-sales 100.0.11 requires magento/framework 100.0.* -> satisfiable by magento/framework[100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.0.8, 100.0.9, 100.0.10, 100.0.11, 100.0.12, 100.0.13, 100.0.14, 100.0.15, 100.0.16, 100.0.17, 100.0.18, 100.0.19, 100.0.20].
- magento/module-sales 100.0.12 requires magento/framework 100.0.* -> satisfiable by magento/framework[100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.0.8, 100.0.9, 100.0.10, 100.0.11, 100.0.12, 100.0.13, 100.0.14, 100.0.15, 100.0.16, 100.0.17, 100.0.18, 100.0.19, 100.0.20].
- magento/module-sales 100.0.13 requires magento/framework 100.0.* -> satisfiable by magento/framework[100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.0.8, 100.0.9, 100.0.10, 100.0.11, 100.0.12, 100.0.13, 100.0.14, 100.0.15, 100.0.16, 100.0.17, 100.0.18, 100.0.19, 100.0.20].
- magento/module-sales 100.0.14 requires magento/framework 100.0.* -> satisfiable by magento/framework[100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.0.8, 100.0.9, 100.0.10, 100.0.11, 100.0.12, 100.0.13, 100.0.14, 100.0.15, 100.0.16, 100.0.17, 100.0.18, 100.0.19, 100.0.20].
- magento/module-sales 100.0.15 requires magento/framework 100.0.* -> satisfiable by magento/framework[100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.0.8, 100.0.9, 100.0.10, 100.0.11, 100.0.12, 100.0.13, 100.0.14, 100.0.15, 100.0.16, 100.0.17, 100.0.18, 100.0.19, 100.0.20].
- magento/module-sales 100.0.16 requires magento/framework 100.0.* -> satisfiable by magento/framework[100.0.2, 100.0.3, 100.0.4, 100.0.5, 100.0.6, 100.0.7, 100.0.8, 100.0.9, 100.0.10, 100.0.11, 100.0.12, 100.0.13, 100.0.14, 100.0.15, 100.0.16, 100.0.17, 100.0.18, 100.0.19, 100.0.20].
- magento/module-sales 100.1.0-rc1 requires magento/framework 100.1.* -> satisfiable by magento/framework[100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.1.1, 100.1.2, 100.1.3, 100.1.4, 100.1.5, 100.1.6, 100.1.7, 100.1.8, 100.1.9, 100.1.10, 100.1.11, 100.1.12].
- magento/module-sales 100.1.0-rc2 requires magento/framework 100.1.* -> satisfiable by magento/framework[100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.1.1, 100.1.2, 100.1.3, 100.1.4, 100.1.5, 100.1.6, 100.1.7, 100.1.8, 100.1.9, 100.1.10, 100.1.11, 100.1.12].
- magento/module-sales 100.1.0-rc3 requires magento/framework 100.1.* -> satisfiable by magento/framework[100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.1.1, 100.1.2, 100.1.3, 100.1.4, 100.1.5, 100.1.6, 100.1.7, 100.1.8, 100.1.9, 100.1.10, 100.1.11, 100.1.12].
- magento/module-sales 100.1.0 requires magento/framework 100.1.* -> satisfiable by magento/framework[100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.1.1, 100.1.2, 100.1.3, 100.1.4, 100.1.5, 100.1.6, 100.1.7, 100.1.8, 100.1.9, 100.1.10, 100.1.11, 100.1.12].
- magento/module-sales 100.1.1 requires magento/framework 100.1.* -> satisfiable by magento/framework[100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.1.1, 100.1.2, 100.1.3, 100.1.4, 100.1.5, 100.1.6, 100.1.7, 100.1.8, 100.1.9, 100.1.10, 100.1.11, 100.1.12].
- magento/module-sales 100.1.2 requires magento/framework 100.1.* -> satisfiable by magento/framework[100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.1.1, 100.1.2, 100.1.3, 100.1.4, 100.1.5, 100.1.6, 100.1.7, 100.1.8, 100.1.9, 100.1.10, 100.1.11, 100.1.12].
- magento/module-sales 100.1.3 requires magento/framework 100.1.* -> satisfiable by magento/framework[100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.1.1, 100.1.2, 100.1.3, 100.1.4, 100.1.5, 100.1.6, 100.1.7, 100.1.8, 100.1.9, 100.1.10, 100.1.11, 100.1.12].
- magento/module-sales 100.1.4 requires magento/framework 100.1.* -> satisfiable by magento/framework[100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.1.1, 100.1.2, 100.1.3, 100.1.4, 100.1.5, 100.1.6, 100.1.7, 100.1.8, 100.1.9, 100.1.10, 100.1.11, 100.1.12].
- magento/module-sales 100.1.5 requires magento/framework 100.1.* -> satisfiable by magento/framework[100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.1.1, 100.1.2, 100.1.3, 100.1.4, 100.1.5, 100.1.6, 100.1.7, 100.1.8, 100.1.9, 100.1.10, 100.1.11, 100.1.12].
- magento/module-sales 100.1.6 requires magento/framework 100.1.* -> satisfiable by magento/framework[100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.1.1, 100.1.2, 100.1.3, 100.1.4, 100.1.5, 100.1.6, 100.1.7, 100.1.8, 100.1.9, 100.1.10, 100.1.11, 100.1.12].
- magento/module-sales 100.1.7 requires magento/framework 100.1.* -> satisfiable by magento/framework[100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.1.1, 100.1.2, 100.1.3, 100.1.4, 100.1.5, 100.1.6, 100.1.7, 100.1.8, 100.1.9, 100.1.10, 100.1.11, 100.1.12].
- magento/module-sales 100.1.8 requires magento/framework 100.1.* -> satisfiable by magento/framework[100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.1.1, 100.1.2, 100.1.3, 100.1.4, 100.1.5, 100.1.6, 100.1.7, 100.1.8, 100.1.9, 100.1.10, 100.1.11, 100.1.12].
- magento/module-sales 100.1.9 requires magento/framework 100.1.* -> satisfiable by magento/framework[100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.1.1, 100.1.2, 100.1.3, 100.1.4, 100.1.5, 100.1.6, 100.1.7, 100.1.8, 100.1.9, 100.1.10, 100.1.11, 100.1.12].
- magento/module-sales 100.1.10 requires magento/framework 100.1.* -> satisfiable by magento/framework[100.1.0-rc1, 100.1.0-rc2, 100.1.0-rc3, 100.1.0, 100.1.1, 100.1.2, 100.1.3, 100.1.4, 100.1.5, 100.1.6, 100.1.7, 100.1.8, 100.1.9, 100.1.10, 100.1.11, 100.1.12].
- Can only install one of: magento/framework[101.0.1, 100.0.2].
- Can only install one of: magento/framework[101.0.1, 100.0.3].
- Can only install one of: magento/framework[101.0.1, 100.0.4].
- Can only install one of: magento/framework[101.0.1, 100.0.5].
- Can only install one of: magento/framework[101.0.1, 100.0.6].
- Can only install one of: magento/framework[101.0.1, 100.0.7].
- Can only install one of: magento/framework[101.0.1, 100.0.8].
- Can only install one of: magento/framework[101.0.1, 100.0.9].
- Can only install one of: magento/framework[101.0.1, 100.1.0-rc1].
- Can only install one of: magento/framework[101.0.1, 100.1.0-rc2].
- Can only install one of: magento/framework[101.0.1, 100.1.0-rc3].
- Can only install one of: magento/framework[101.0.1, 100.1.0].
- Can only install one of: magento/framework[101.0.1, 100.0.10].
- Can only install one of: magento/framework[101.0.1, 100.0.11].
- Can only install one of: magento/framework[101.0.1, 100.1.1].
- Can only install one of: magento/framework[101.0.1, 100.0.12].
- Can only install one of: magento/framework[101.0.1, 100.1.2].
- Can only install one of: magento/framework[101.0.1, 100.1.3].
- Can only install one of: magento/framework[101.0.1, 100.0.13].
- Can only install one of: magento/framework[101.0.1, 100.1.4].
- Can only install one of: magento/framework[101.0.1, 100.0.14].
- Can only install one of: magento/framework[101.0.1, 100.1.5].
- Can only install one of: magento/framework[101.0.1, 100.0.15].
- Can only install one of: magento/framework[101.0.1, 100.1.6].
- Can only install one of: magento/framework[101.0.1, 100.1.7].
- Can only install one of: magento/framework[101.0.1, 100.0.16].
- Can only install one of: magento/framework[101.0.1, 100.0.17].
- Can only install one of: magento/framework[101.0.1, 100.1.8].
- Can only install one of: magento/framework[101.0.1, 100.1.9].
- Can only install one of: magento/framework[101.0.1, 100.0.18].
- Can only install one of: magento/framework[101.0.1, 100.0.19].
- Can only install one of: magento/framework[101.0.1, 100.1.10].
- Can only install one of: magento/framework[101.0.1, 100.1.11].
- Can only install one of: magento/framework[101.0.1, 100.0.20].
- Can only install one of: magento/framework[101.0.1, 100.1.12].
- Installation request for magento/framework (locked at 101.0.1) -> satisfiable by magento/framework[101.0.1].


Installation failed, reverting ./composer.json to its original content.

Does this require a composer update to install successfully?

1

This is happening because probably packagist is not updated with the last module version that you see on github. If you run "composer require adfab/m2-module-gdpr" this will fetch the module from the packagist repository.

Instead of pulling the module from packagist, try to add it manually as a vcs (private repository) to your composer.json.

Inside the repositories include the github link like this example:

"repositories": [

        "type": "composer",
        "url": "https://repo.magento.com/"
    },
    {
        "type": "vcs",
        "url": "https://github.com/AdFabConnect/magento2gdpr.git"
    }
],

In the require section add it like that:

    "require": {
    "magento/product-community-edition": "2.2.1",
    "composer/composer": "@alpha",

    "adfab/m2-module-gdpr": "dev-master"
},

Note: in this example im installing dev-master. You can install the version you prefer.

Add the dependencies as well in require dev:

"require-dev": {

    "fzaninotto/faker": "*",
    "magento/module-customer": "*",
    "magento/module-quote": "*",
    "magento/module-sales": "*",
    "sabas/edifact": "*"
},

All you have to do now is run:

composer update
bin/magento setup:upgrade --keep-generated
bin/magento cache:clean

The message after running the composer update should look like that:

composer update

Let me know if this work for you.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.