1

In my base url not have index.php, but my all categories and products url consists index.php. How can i remove this.

Note : Base url have not index.php

  • Please clear your cache and check it again. – Dhaduk Mitesh Apr 4 '18 at 5:45
0

Have you enabled this option ?

Login to Admin and got to :

System->Configurations->Web

and then in "Search Engine Optimization Tab" select Yes

| improve this answer | |
  • Yes, already the option is yes. – zus Apr 4 '18 at 5:44
  • then check if mode_rewrite enabled on your server and .htaccess ? – Naveed Asim Apr 4 '18 at 5:45
  • How can i enable mode_rewrite in both server and .htaccess? – zus Apr 4 '18 at 5:49
  • 1
    check this post link to know how to enable mode_rewrite, stackoverflow.com/questions/869092/… – Naveed Asim Apr 4 '18 at 5:52
  • after changes in .htaccess stil not working -> screen shot snag.gy/pMUD27.jpg – zus Apr 4 '18 at 6:38
0

Please go to this path in your Magento,

System -> Configuration -> General -> Web -> Search Engines Optimization

And set Use Web Server Rewrites to YES.

After doing this please refresh your cache and check it.

| improve this answer | |
  • Yes, already the option is yes – zus Apr 4 '18 at 5:50
0
  1. Go to System -> Configuration -> General -> Web -> Search Engines Optimization And set Use Web Server Rewrites to YES.
  2. Take backup of previous both .htaccess files then again Upload .htaccess and .htaccesssample files into your server.
  3. Clear your cache and do re-index management again.
| improve this answer | |
  • Still not working, .htaccess changes -> snag.gy/pMUD27.jpg – zus Apr 4 '18 at 6:38
  • may i know the possibilities of error. – zus Apr 4 '18 at 6:40
  • @zus, As of i told, reupload .htaccess files both. then you will get the sucess – Teja Bhagavan Kollepara Apr 4 '18 at 6:52
0

To remove index.php from URLs follow the below steps :

Log-in Magento Admin.
Go to System -> Configuration -> Web.
From Search Engine Optimisation tab Use Web Server Rewrites select YES.
Make sure your Secure and Unsecure base urls should end with “/”.
| improve this answer | |
  • may i know the possibilities of error. – zus Apr 4 '18 at 6:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.