1

This question already has an answer here:

I'm trying to get my site to https, but I'm getting file mix error, I made the changes I found there but did not get results. Is there any additional configuration?

ERROR:

Mixed Content: The page at 'https://www.mydomain.com.br/' was loaded over HTTPS, but requested an insecure stylesheet 'http://www.mydomain.com.br/skin/frontend/ultimo/default/css/styles.css'. This request has been blocked; the content must be served over HTTPS.

Magento config

Magento Config

marked as duplicate by Manoj Deswal, Jai, Dhiren Vasoya, Priyank, Piyush Apr 3 '18 at 4:47

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Do you have SSL Certificate on your server? – St3phan Apr 2 '18 at 12:37
  • Yes, by incapsula – Gustavo Souza Apr 2 '18 at 12:39
3

Force HTTPS throughout the store may fix your issue. You can do that by specifying HTTPS URL in unsecure base URL as well. It may be caused by loading the css with unsecure base URL somewhere in your code directly.

Or just use the condition Mage::app()->getStore()->isCurrentlySecure() to check if HTTPS is enabled and get HTTPS URL for the css declaration you've done.

  • Depending on your customization(s), you may have to dig through your code to find every instance that you pulled a url and make sure it is secure. In the case of your example (a skin_css file), it should be resolved with this answer from @vignesh – mtr.web Apr 2 '18 at 19:48
  • Also - just do a double check to make sure your store and website url configs are updated when forcing this as well. Simple, but I have missed one before. – camdixon Apr 3 '18 at 1:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.